300tdi speedometer cable - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-05-2006, 11:35 AM Thread Starter
Member
 
Join Date: Jan 2006
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
300tdi speedometer cable

hi i have jus got my first landrover, a blue defender 90, with a 300tdi engine conversion, the speedo has stopped working while driving home, the cable is connected at the dash and it seems to be attached okay on the transfere box but is a little loose.
dose anyone know how to repair it or find out whats wrong, the cable aint snapped because it wont pull through at the dashboard end.
any pictures would be great.

also my heater box needs replacing as its leaking coolant, iv undont the 2 bottom retaining nuts and its still fixed solid any ideas?.

thanx
saitan_jnr is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 03-06-2006, 07:37 AM
Premium Member
 
TerryS's Avatar
 
Join Date: Aug 2004
Location: Bloomfield, CT If I died today, I lived there all my life.
Posts: 3,321
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The inner cable will slide out of it's jacket from one end, but not the other, and I'm sorry to say I can't remember which. One end has a small flange, and I'm thinking its the head end.. Very little of the cable engages the square hole of the speedo drive, so if the clamp holding the jacket to the transfer case is loose, it may have become disengaged. They cable is the same as those used on series 3, the one with the clip-on head end. Be careful removing it, as the clip has a pretty consistent habit of breaking.
TerryS is offline  
post #3 of 3 (permalink) Old 03-07-2006, 02:02 PM Thread Starter
Member
 
Join Date: Jan 2006
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
got it sorted

cheers mate, i got it sorted today, the cable had come out of the square on the transfer box. managed to fit a new radiator to the heating too.
saitan_jnr is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Defender

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome