Chugging sound When Accelerating - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-21-2016, 08:38 AM Thread Starter
Member
 
Join Date: Aug 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thumbs down Chugging sound When Accelerating

Please Help Diagnose:

-It started as a faint chug every now and then.
-It has now progressed to quite a prominent chugging when accelerating.
-It only happens when the gears are engaged.
-When in neutral and revving, nothing.
-When driving and it is highly audible, It goes away when i press the clutch in.
-It gets faster as the car does and slows when the car does.

What is it?

Cheers in advance! FD
FontonDoodler is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Defender

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Chugging sound - Please help diagnose slaphappy Discovery Series II 5 03-03-2013 08:13 AM
1997 RR HSE 4.6 Chirping sound at first, puffing sound now no heat no a/c DJKilmer Range Rover P38, Mk III and Range Rover Sport 0 06-14-2012 04:46 PM
Engine is chugging when I accelerate brandr Discovery Series II 6 07-15-2009 10:42 AM
vibration/rumbling sound while accelerating prettynpink1029 Discovery Series II 6 05-02-2009 04:57 AM
Chugging / Missing Disco 98 at cold-start Pedro_malo Discovery Series I 1 07-28-2008 12:58 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome