Help PLEASE! - Land Rover Forums : Land Rover and Range Rover Forum
» Auto Insurance
» Featured Product
Wheel & Tire Center

LandRoversOnly.com is the premier Land Rover Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-25-2013, 11:20 AM   #1 (permalink)
Senior Member
 
RPM289's Avatar
 
Join Date: Jun 2011
Posts: 110
Gallery: 0
Default Help PLEASE!

My 91 RRC has decided to give me trouble again. It has been running good with thte exception of valve train noise. It has decided it will start and idle but if you try to give it any gas it bogs down or quits. Any idea what is causing this?

Thanks,

Mike
RPM289 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-25-2013, 11:56 AM   #2 (permalink)
Senior Member
 
John C's Avatar
 
Join Date: Nov 2004
Location: Tappan, NY
Posts: 1,504
Gallery: 0
Default

Clogged cats, IACV, MAF, TPS..... bad fuel filter.... could be a bunch of stuff. Give us some more infor on what you have checked or replaced and maybe we can help you.

Try adding your location to your profile, you never know who lives by you and can lend a hand.

Good luck.
__________________
John C

1999 DI - LR HD Springs
1996 DI - parting out
1995 DI - parting out Scorpion Racing Extreme Kit
1994 RRC LWB - 3" AG lift
1991 RR - parting out (few parts left)
1990 Kawasaki KL650B Tengai - parting out
1989 Kawasaki KLR650
1988 Kawasaki KLR650 - parting out
1979 Puch XK
1980 Puch Magnum MKII
1980 Puch Magnum MKII - parting out
John C is offline   Reply With Quote Quick reply to this message
Old 01-25-2013, 06:35 PM   #3 (permalink)
Senior Member
 
RPM289's Avatar
 
Join Date: Jun 2011
Posts: 110
Gallery: 0
Default

Here is what I have tried with no change in issue. The TPS is new, Unplugged mass air meter no change, unplugged the following Temp sensor, fuel press switch, Air bypass, TPS, Mass air meter, Rover was idling when unplugging things to see if it changes. There are no cats, exhaust is flowing. Fuel pump and filter is 6 mo old. IGN is a 95 ist with a MSD 6A box and Tach adapter. I am in Phenix City,AL if someone can stop by and help me out.
RPM289 is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 10:28 AM   #4 (permalink)
Senior Member
 
RPM289's Avatar
 
Join Date: Jun 2011
Posts: 110
Gallery: 0
Default

I am thinking ti may be the fuel pump again no way to confirm... I have to get $ to buy the fuel press gauge for my Rover from PT!!!!!
RPM289 is offline   Reply With Quote Quick reply to this message
Old 01-29-2013, 05:10 PM   #5 (permalink)
Senior Member
 
RPM289's Avatar
 
Join Date: Jun 2011
Posts: 110
Gallery: 0
Default

Well it was the fuel line in the tank deteriorated and collapsing i replaced the fuel pump again cause it was under warranty for 2 more months. Rover is running again!
RPM289 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rovers Only General Forums > General Land Rover Discussion


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 11:49 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
All content is copyright 2004-2008 www.landroversonly.com and its original authors. Land Rovers Only is in no way affiliated with Land Rover