Login problem - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-05-2015, 08:51 AM Thread Starter
Member
 
Join Date: Mar 2012
Location: Traverse City, Michigan
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage
Login problem

It seems that I have to supply a user name each time I access the forum, in spite of checking "Remember me". This is a little annoying and will keep me from accessing the forum as often as in the past.

Steve

2000 Discovery - Chawton White, '04 CDL, 180F OEM thermostat, 99K.
Steve517 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-05-2015, 11:38 AM
Rover-Holic and Admin
 
ArmyRover's Avatar
 
Join Date: Sep 2007
Location: Augusta, GA
Posts: 7,288
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Check your settings your browser could be causing the issue.

I've had no problems with google chrome

1972 MGB
Coming Soon 2006 LR3
Trident Green, 1983 110

Need new parts, genuine Land Rover, aftermarket and off road upgrades, Support the Vendor that supports the Land Rover Community and Forum
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
716-898-8153

Have a DII you need a drive shaft click here
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Want a
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
best read this first
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Need used parts?
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ArmyRover is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rovers Only General Forums > Board Announcements

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
has anyone had this problem foothills General Land Rover Discussion 5 03-26-2012 04:05 AM
Does anyone else have these problem???? Discodude Discovery Series II 3 07-22-2009 05:08 AM
90 RRC with another problem, may even be the same problem! Ohlmin Range Rover Classic 8 06-21-2009 08:08 PM
Problem trendy Discovery Series I 4 10-25-2004 06:46 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome