Help - Radio goes DEAD for no reason! - Land Rover Forums : Land Rover and Range Rover Forum
» Auto Insurance
» Featured Product
Wheel & Tire Center

LandRoversOnly.com is the premier Land Rover Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-02-2009, 10:02 PM   #1 (permalink)
Member
 
Join Date: Aug 2009
Posts: 7
Gallery: 0
Unhappy Help - Radio goes DEAD for no reason!

We just got our 06 RR Supercharged and the sound system goes dead while driving. Nothing works on the screen and sometimes, it goes blank or just shows the Land Rover logo screen. The power light flashes, no sound.

Sometimes it'll start back up.

It got very bad today. We took it to the dealership and the factory warranty expired 2 weeks ago - they wouldn't take the car.

I tried charging the battery and it never fully charges. I had a friend test the battery - while it was running and the tester shows that the batter is good.
However, it also showed erratic readings from the Alternator.

My question is, if the alternator is indeed bad or flaky, would this cause the symptoms I am having with the electronics??

I will try to take it to the dealer again, this time I have an extended warranty (non-Land Rover though) but I'm hoping this is a simple and common issue?

thanks,
DarthRover is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-02-2009, 10:09 PM   #2 (permalink)
House Trained
 
Prodigy999's Avatar
 
Join Date: Jul 2009
Location: Los Angeles, CA
Posts: 371
Gallery: 0
Default

Happens all the time. More than likely the bluetooth module has taken a dump but you gotta get it diagnosed. Modules on that system are: radio head unit, display module, rear entertainment module, audio amplifier, satellite radio module, cell phone module. Any one of those fail or have communication problems, it will fault the whole system.
__________________
03 Disco diff locked rig
04 Disco stocker
Prodigy999 is offline   Reply With Quote Quick reply to this message
Old 09-03-2009, 01:45 AM   #3 (permalink)
Member
 
Join Date: Aug 2009
Posts: 7
Gallery: 0
Default

Thanks for the info, I will need to get it to the dealer asap I guess. Hopefully the 3rd party extended warranty covers it.

Looked at the compponents and there was some corrosion on the connector going into the Bluetooth module, Nokia rx-1m.
I tried to clean it but I figure it's shorted out and broken.
I bet the little piece would cost a lot.
DarthRover is offline   Reply With Quote Quick reply to this message
Old 09-09-2009, 01:22 AM   #4 (permalink)
Member
 
Join Date: Aug 2009
Posts: 7
Gallery: 0
Default

Am I getting ripped off?
The dealer got the Truck today and they want to charge me an Extra $270 to diagnose the problem with the radio/nav system.
They say they have to use another Range Rover and swap parts until they figure which component has failed!

Doesn't land rover have testing equipment fir this ?

Is there a corporate number to reach land rover?
DarthRover is offline   Reply With Quote Quick reply to this message
Old 09-09-2009, 08:32 AM   #5 (permalink)
Member
 
Join Date: Sep 2009
Posts: 3
Gallery: 0
Default ripped off or not...

here is the number for land rover OWNER customer service. they have been excellent the times that i have spoken with them.
1.800.637.6837
you can find the number by going to the land rover usa site and under contact us it is listed.
good luck.
metreobx is offline   Reply With Quote Quick reply to this message
Old 09-11-2009, 11:44 PM   #6 (permalink)
Member
 
Join Date: Aug 2009
Posts: 7
Gallery: 0
Default

The Land Rover Dealer made good after all. At first, they wanted to charge me for 4 extra hours of diagnostics that the warranty company would not pay for. In the end, they knocked off the extra hours and charged me only the deductible.

It turned out to be the bluetooth module, as I suspected, and it brought down the whole radio/dvd/nav system. Now everything is working just fine!

The service guys at Monterey Land Rover did right by me after all, thanks!
DarthRover is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Range Rover P38, Mk III and Range Rover Sport


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
radio and stuff dead rmxr3 Discovery Series I 1 03-23-2009 03:43 PM
97 LRRR 4.0 SE - Radio Fuse Location vjm530 Range Rover P38, Mk III and Range Rover Sport 1 01-12-2009 02:06 AM
Radio Dead! Rick C Range Rover Classic 2 05-15-2007 09:47 AM
Got Radio Gremlins!! ARGG!! LANDY96 Range Rover Classic 6 10-30-2006 02:37 PM
No Power to Radio, need help please tomkat Discovery Series I 8 10-02-2006 02:36 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:48 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.