Boatload of ABS Codes - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 11-10-2012, 05:53 PM Thread Starter
Member
 
Join Date: Oct 2012
Location: Johannesburg, South Africa
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Boatload of ABS Codes

Hi all. My ABS Amigo has given me a ton of codes and I have no clue where to begin with this. Should I replace all the wheel speed sensors independently? Replace ABS unit? Shuttle valve (although 114 is one of the few codes I DIDN'T get)? Any advice on where to begin? I am a complete n00b.

Here is the ABS Amigo output:

-----ABS Amigo Box V1 RSW Solutions LLC Copyright 2010-----
|* The information provided is without warranty of any kind.*|
|* IN NO EVENT SHALL RSW Solutions BE LIABLE FOR ANY LOSS OR*|
|* INJURY OR DAMAGES resulting from or connected to use of *|
|* this Information or Product. YOU HEREBY WAIVE ANY AND ALL*|
|* CLAIMS AGAINST RSW Solutions ARISING OUT OF YOUR USE OF *|
|* THIS INFORMATION OR PRODUCT. *|
--------------------------------------------------------------
1.--Current Faults---->
Active Faults:
None
Logged Faults:
Front Left Sensor Bad Output
<-END Faults
------------------------------------------------------------
* *
------------------------------------------------------------
..--Previous Faults--->
Active Faults:
Front Left Sensor Bad Output
032:Front Left in valve open circuit
036:Rear Left in valve open circuit
057:Rear Left out valve short to Gnd
061:Brake light relay short to Gnd
066:Front Left sensor electric fail
067:Rear Right sensor electric fail
072:Front Left in valve short to supply
Front Right Sensor Bad Output
Rear Right Sensor Bad Output
091:Front Right out valve drive short to Supply
093:Front Left out valve drive short to Supply
096:Rear Left in valve drive short to Supply
101:Brake light relay drive short to Supply
110:Sticking throttle
Comms Error
Logged Faults:
Comms Error
<-END Faults
------------------------------------------------------------
* *
------------------------------------------------------------
..--Previous Faults--->
Active Faults:
None
Logged Faults:
None
<-END Faults
------------------------------------------------------------
* *
------------------------------------------------------------

2003 Discovery II V8, 105,000 miles
slaphappy is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 11-10-2012, 06:04 PM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,595
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I believe you also posted on the LRF, go read and follow my directions.

Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link http://www.landroverresource.com/

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm


Need Parts?
paulgrant@mac.com or call 203-770-1699
willtillery@roverguy.com or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8, http://lucky8llc.com/
British Parts of Utah, http://www.bputah.com/
Disco Mike is offline  
post #3 of 6 (permalink) Old 11-10-2012, 07:02 PM Thread Starter
Member
 
Join Date: Oct 2012
Location: Johannesburg, South Africa
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sorry, but it wasn't me. Would love to read your advice though, particularly if the person on the other forum had similar issues. Do you happen to have a link to that thread? Thanks

2003 Discovery II V8, 105,000 miles
slaphappy is offline  
post #4 of 6 (permalink) Old 11-11-2012, 04:43 AM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,595
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Sorry, there was another, near exact post on the LRF. First go clean and tighten you battery cable and grounds, then have a local parts store do a free charging system test, your voltage has to be between 13.6 and 14.4 volts.
If all is well, then clear your ABS codes a couple of times and see what new ones show up.

Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link http://www.landroverresource.com/

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm


Need Parts?
paulgrant@mac.com or call 203-770-1699
willtillery@roverguy.com or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8, http://lucky8llc.com/
British Parts of Utah, http://www.bputah.com/
Disco Mike is offline  
post #5 of 6 (permalink) Old 11-11-2012, 10:26 PM Thread Starter
Member
 
Join Date: Oct 2012
Location: Johannesburg, South Africa
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks Mike. Will do. I tried to test the voltage myself with a multimeter. Granted that I have no clue what I'm doing, it looked to me like the voltage was about 13.9 with the engine running and about 12.6 with the engine turned off. But like I said, I don't really know what I'm doing so I will take it someplace to have the charging system checked.

To help me understand what I'm doing, is the theory here that if the charging system is not operating properly, then electrical weirdness could be causing all the above error codes together rather than each one being caused individually by an underlying part issue?

2003 Discovery II V8, 105,000 miles
slaphappy is offline  
post #6 of 6 (permalink) Old 11-12-2012, 04:28 AM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,595
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Looks like your voltage is OK so clear the code, and drive it till they come back then get back to me with the new codes.

Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link http://www.landroverresource.com/

Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm


Need Parts?
paulgrant@mac.com or call 203-770-1699
willtillery@roverguy.com or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8, http://lucky8llc.com/
British Parts of Utah, http://www.bputah.com/
Disco Mike is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Finaly got ABS codes. Now what? 03DISCOHP Discovery Series II 10 06-22-2012 03:50 PM
ABS Amigo Codes....what do they mean? Redvalley Discovery Series II 5 01-09-2012 12:23 PM
Need help with ABS Amigo Codes adamgrn Discovery Series II 5 12-15-2011 03:10 PM
Pulled the ABS Codes with my new ABS Amigo j.haffly Discovery Series II 7 09-07-2011 04:00 PM
ABS codes read mtd77246 Discovery Series II 3 12-31-2008 10:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome