Frozen Nav/Info Screen - Land Rover Forums : Land Rover and Range Rover Forum
» Auto Insurance
» Featured Product
Wheel & Tire Center

LandRoversOnly.com is the premier Land Rover Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-04-2010, 09:34 AM   #1 (permalink)
Member
 
Join Date: Mar 2010
Location: Coastal Georgia
Posts: 15
Gallery: 0
Default Frozen Nav/Info Screen

Hello All,

I am new to this forum, but I am finding it very useful as I begin to experience more of the little quirks of Land Rover ownership. I have an 08 LR3 HSE with 18k on it. Last night I fired it up to drive home and the nav screen froze on the Land Rover symbol that is displayed when you open the car. It never moved from the logo for the hour long drive home. It would not respond to any input via touch or the buttons. Anyone else had this happen before? I have not checked to see that it is working yet today as I drove another vehicle to work, but I imagine it works just fine now Any thought would be appreciated.

Many thanks...
mikkenspeed is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-19-2011, 08:08 PM   #2 (permalink)
Member
 
Join Date: Apr 2011
Posts: 1
Gallery: 0
Default Radio / Nav froze

I have a 2000 range rover and facing the same problem. My radio / nav system has frozen and only shows the land rover logo. Am unable to even turn on or turn off. Please let me know if this got resolved.
sroopa is offline   Reply With Quote Quick reply to this message
Old 04-20-2011, 06:17 AM   #3 (permalink)
Member
 
Sasquatch's Avatar
 
Join Date: Jan 2010
Posts: 95
Gallery: 0
Default

Since you're still under warranty, set up an appt with the Dealer and have them re-flash with an update CD.
Sasquatch is offline   Reply With Quote Quick reply to this message
Old 04-20-2011, 03:32 PM   #4 (permalink)
Senior Member
 
roverandom's Avatar
 
Join Date: Apr 2007
Location: Alberta,Canada.
Posts: 2,042
Gallery: 0
Default

Your view screen has lost communication with the amp and CD ROM drive under the front seats is one possible cause. There is a TSB on pinched wires to do with this. Mine had corroded connections along the passenger side sill trim panel and caused the exact same symtom.

There are also software updates available as this has also been traced to computer problems in the past.
__________________
"Your only supposed to blow the BLOODY DOORS OFF" Charlie Croaker. The Italian Job. 1969.

Matt.
roverandom is offline   Reply With Quote Quick reply to this message
Old 04-21-2011, 09:09 AM   #5 (permalink)
Member
 
Join Date: Mar 2010
Location: Coastal Georgia
Posts: 15
Gallery: 0
Default

Well it has been a bit over a year since I posted this, but thanks for the replies. To update you, I did have the problem repeat one additional time. I took it to the dealer and they of course were not able to replicate the problem, but did reflash the electronics. Knock on wood, it has not happened since. I hope this helps. Thanks again for the posts.
mikkenspeed is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery 3 / LR3


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How is the tv/nav screen removed ? g.farrell Range Rover P38, Mk III and Range Rover Sport 2 12-02-2010 06:55 PM
Frozen Gear Box??? Boular Discovery Series I 6 12-13-2009 12:08 PM
O2 sensor frozen kazzin Discovery Series II 4 09-27-2009 02:47 PM
02RR Radio speakers out/Nav screen turns white ztrex Range Rover P38, Mk III and Range Rover Sport 1 06-11-2008 12:14 PM
frozen radiator, Umm Ya. Corbit Range Rover Classic 11 12-10-2006 06:15 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:49 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.