1995 Discovery 1- passenger side cylinders not firing - Land Rover Forums : Land Rover and Range Rover Forum
 1Likes
  • 1 Post By peter r
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-26-2017, 03:35 PM Thread Starter
Member
 
Join Date: Feb 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation 1995 Discovery 1- passenger side cylinders not firing

I have a 1995 Disco 1 with rebuilt motor-heads replacement etc. Vehicle cranks up with very rough idle, running only on 4 cylinders drivers side. Just installed new fuel injectors, power to injectors seems to be good from wiring harness, 32 -34 psi on fuel rail, spark from new wires and plugs but fuel injectors seem to not be receiving signal to distribute fuel. My guess anyway. Any ideas on problem? Could it be bad ECU? If the ECU is bad will it still run on 4 cylinders? Any help would be greatly appreciated.
Thanks
Mid Florida Disco 1 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-03-2017, 10:50 AM
Senior Member
 
Join Date: Nov 2008
Location: Chicagoland, IL
Posts: 268
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
1995 should be a distributor engine. I'd look there for your lack of spark.
fishEH is offline  
post #3 of 6 (permalink) Old 03-04-2017, 01:12 PM
Special Agent
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,138
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Garage
Sounds like injector control the way I read it.
How did it run before the engine work?

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
 
post #4 of 6 (permalink) Old 03-04-2017, 03:41 PM
Ian Matthews
 
p76rangie's Avatar
 
Join Date: Jan 2006
Location: Melbourne Australia
Posts: 5,046
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 150 Post(s)
Yes, one bank's injectors fire at the same time and on a single circuit. So it is possible that there is something wrong with that circuit that is stopping a whole bank from firing.
p76rangie is offline  
post #5 of 6 (permalink) Old 03-26-2017, 02:03 PM
Member
 
Join Date: Mar 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Not sure if this makes sense, but mine was doing the exact same thing. I bought it cheap from a guy who thought the engine was blown. Found a coil behind the engine, replaced it and runs perfectly.
Dave Peterson is offline  
post #6 of 6 (permalink) Old 04-04-2017, 03:54 AM
Member
 
Join Date: Mar 2017
Location: Victoria Au
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
G`day ,

I didn`t read the heading you do say pass side , so you`ll look at pin 11 YW .

The ECU uses pin 11 AND pin 13 to alternately earth each bank .

Pin 11 uses YW yellow/white to earth cylinders 2 , 4 , 6 and 8.

Pin 13 uses YU yellow/blue to earth cylinders 1 , 3 , 5 and 7 .

The main relay , pin 87 power all the injectors via NO brown/orange .

If it runs on one bank you`ll have power to all eight injectors because it uses one wire the NO .

You should be able to check the continuity of the YW and YU wires by un pluging the ECU and check that the ECU pins 11 and 13 are earthing .
redtruck12 likes this.

84/5 RR 4.0ltr Torqueflite Standard

93/4 RR 3.9ltr ZF Hard dash Vouge SE

94/5 RR 4.6ltr ZF Soft Dash Vouge SE

03/4 RR 3.0ltr TD6 GM HSE

Last edited by peter r; 04-04-2017 at 06:48 PM.
peter r is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 RRLWB Passenger side lights Jason Durant Walker Range Rover Classic 1 02-06-2017 03:30 PM
96 disco 1 not firing on all 8 cylinders all the time DiscoChris10 Discovery Series I 4 08-28-2012 04:05 PM
Discovery 1 02 Sensor plug - Red on Passenger Side? pbsled Discovery Series I 5 12-15-2010 03:19 PM
multiple misfires again... 4 "passenger side" cylinders misfiring prettynpink1029 Discovery Series II 27 02-11-2009 06:12 AM
Discovery 1 passenger side running board/side step roverpwr Land Rover Parts and Vehicles Wanted 12 04-09-2007 06:20 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome