injectors not pulsing 95 3.9 auto - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-04-2008, 06:36 PM Thread Starter
Member
 
Join Date: Apr 2008
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
injectors not pulsing 95 3.9 auto

does anyone know what would cause the injectors not to fire?what triggers the injectors to pulse? I have tried another ecu and still no injector pulse. the 95 has a distributor, no cam sensor, no crank sensor. is there a relay for the injectors? does the ecu get a signal from the ignition system like the old bocsh systems did with the tach input. i am baffled
bobm7007 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 05-05-2008, 06:05 AM
Senior Member
 
Elemental's Avatar
 
Join Date: Feb 2007
Posts: 4,408
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The computer needs to see at least 50 rpm on the tach signal(off the coil) before it turns on the injectors.
Elemental is offline  
post #3 of 6 (permalink) Old 02-29-2012, 10:35 AM
Member
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
no pulse

I have the same problem on mine . How does the computer get that signal.
hornet is offline  
post #4 of 6 (permalink) Old 02-29-2012, 11:11 AM
Senior Member
 
Join Date: Sep 2004
Location: Churubusco, IN
Posts: 4,694
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by hornet View Post
I have the same problem on mine . How does the computer get that signal.
One of the wires on the coil.

Yes, I am still alive, and still in the Rover parts business.
Text me for greatest likelihood of finding me.

260-804-0458

Dominic Perodeau/Global British is a thieving bastard, do not send him money.
PTSchram is offline  
post #5 of 6 (permalink) Old 03-02-2012, 09:28 AM
Member
 
Join Date: Feb 2012
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
No pulse

Yes i found it white wire black strip. Thank you.
hornet is offline  
post #6 of 6 (permalink) Old 03-02-2012, 03:12 PM
Senior Member
 
Join Date: Feb 2011
Location: Queens, NYC
Posts: 407
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by PTSchram View Post
One of the wires on the coil.
I think it's the white wire with bk stipe, off of the (-) terminal on the coil.

Hamal T.

1994 Range Rover County LWB - Sold for Parts
1999 Disco II, 98k, Stock
1999 Kawasaki Ninja ZX-6E - Summer ride to work.
1994 Ford Taurus SHO - Modded Q Ship.
Racer X is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
RRC in need of Help, elemental disco mike various other smart people ArmyRover Range Rover Classic 136 06-09-2008 02:02 PM
Land Rover LRX unveiled, courtesy of Auto Motor und Sport Administrator Land Rover News 7 12-18-2007 11:48 PM
Injectors... advise. texasrover Discovery Series I 7 01-17-2006 05:42 PM
RRC Parts (cheap) Injectors, Cylinder Head, etc... yieldsign2 Land Rover Parts and Accessories 0 01-09-2006 08:02 AM
Injectors... texasrover Discovery Series I 5 07-20-2005 05:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome