Key won't turn in ignition... suggestions? - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 09-29-2011, 06:09 AM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Key won't turn in ignition... suggestions?

Howdy -
key wont turn when placed into the ignition. battery is fine. steering wheel is *not* locked. car is definitely in park. i tried turning key multiple times while moving the steering wheel side to side, etc. took to local LR dealer. over a thousand bucks to replace the ignition assembly.

Is there a better (read: significantly cheaper) option? Any ideas you might have would be most appreciated. Just bought this thing a month ago for about 2K - hard to imagine putting 50% of that into it for a key tumbler...
tyrrhena is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 09-29-2011, 06:35 AM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
The ignition switch assembly is something you could do on your own. Also, I can get you a brand new Land Rover ignition switch for a fraction of what the dealer would charge you.

If you want to go that route, let me know. I can certainly give you step by step instructions regarding the removal and installation of the switch. It shouldn't take a first timer much more than a couple of hours to do. Total cost, under $200.
Paul Grant is offline  
post #3 of 15 (permalink) Old 09-29-2011, 08:25 AM
Member
 
Join Date: Sep 2011
Posts: 87
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Although possibly not as good a solution as the above, here is another approach and it's free...
ignition lock fix - Land Rover Forums - Land Rover Enthusiast Forum
Ed Z is offline  
post #4 of 15 (permalink) Old 09-30-2011, 01:18 PM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Paul - still debating a course of action. I appreciate the quick reply. Will this solve the entirety of the problem?
tyrrhena is offline  
post #5 of 15 (permalink) Old 09-30-2011, 01:20 PM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I can't see how a brand new ignition switch won't solve the problem. Everything will be like it was when the truck was new.
Paul Grant is offline  
post #6 of 15 (permalink) Old 09-30-2011, 01:32 PM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
HI PAUL - my apologies. I am neither good with cars, nor knowledgeable about LRs. Just making sure I understand properly before I make a decision...
tyrrhena is offline  
post #7 of 15 (permalink) Old 09-30-2011, 01:34 PM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
No problem at all. Like I said, if you decide to go this route, I'll help you with directions. I've removed well over 100 of these over the years. Once you get over the notion of what you're doing and focus on the steps, it's really not hard at all.
Paul Grant is offline  
post #8 of 15 (permalink) Old 10-04-2011, 04:08 PM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Paul - interested in moving forward with this here... let me know how to go about reaching you, payment, etc...
tyrrhena is offline  
post #9 of 15 (permalink) Old 10-05-2011, 05:31 AM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I have to see if I can still get the switches. I will get back in touch with you later today.
Paul Grant is offline  
post #10 of 15 (permalink) Old 10-06-2011, 09:27 AM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I sent you a PM. I'm ready when you are.
Thanks,
Paul
Paul Grant is offline  
post #11 of 15 (permalink) Old 10-06-2011, 12:47 PM
Senior Member
 
Join Date: Sep 2004
Location: Churubusco, IN
Posts: 4,695
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Paul Grant View Post
I can't see how a brand new ignition switch won't solve the problem. Everything will be like it was when the truck was new.
Switch or lock assembly?

Yes, I am still alive, and still in the Rover parts business.
Text me for greatest likelihood of finding me.

260-804-0458

Dominic Perodeau/Global British is a thieving bastard, do not send him money.
PTSchram is offline  
post #12 of 15 (permalink) Old 10-06-2011, 12:51 PM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
It's a complete ignition switch assembly. Not just the ignition switch. It's everything right down to two new keys. Even the shear bolts are new.
Paul Grant is offline  
post #13 of 15 (permalink) Old 10-06-2011, 02:05 PM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Paul Grant is offline  
post #14 of 15 (permalink) Old 10-18-2011, 11:02 AM Thread Starter
Member
 
Join Date: Sep 2011
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hey Paul - got the part last night. Talk to the Svc Mgr at the local LR dealer - claims that the one you sent me was for a "manual transmission" Discovery - and that if it gets put in, it will not allow me to shift. That accurate in your experience? He said the part # that I need is STC1436, and the part # that you sent me is STC1435. Need your expertise here... Thanks.
tyrrhena is offline  
post #15 of 15 (permalink) Old 10-18-2011, 11:13 AM
Premium Member
 
Join Date: Jun 2005
Location: CT
Posts: 3,091
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I put a call into my supplier and am waiting for a call back. I will be in touch as soon as I hear from him.
Paul Grant is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alarm armed or bad ignition? key wont turn bikeG976 Discovery Series II 1 12-19-2010 09:49 AM
Ignition key opens the doors and hatch but will not turn in the ignition. sanmigmike Range Rover Classic 3 08-26-2010 06:11 PM
Disco No Go! Ignition Key Will Not Turn! Beirut_Rover Discovery Series I 10 04-17-2008 01:27 PM
Key - difficult to turn in ignition (starting and turning off) mm_putnam@yahoo.com Range Rover Classic 3 11-10-2007 04:21 AM
Ignition Key won't turn galloj Discovery Series II 1 12-03-2005 12:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome