Land Rover Forums : Land Rover and Range Rover Forum - View Profile: Disco Mike
» Auto Insurance
» Featured Product
Wheel & Tire Center

Disco Mike Disco Mike is offline

Administrator

Visitor Messages

Showing Visitor Messages 1 to 10 of 223
  1. GeorgeS_83
    07-11-2014 01:09 PM - permalink
    GeorgeS_83
    Good day Mike,
    Was wondering if you can give more detail in your checklist of like what brand and weight for the engine oil, and power steering fluid. For the spark plugs, is Bosch better than NGK or Champion?
  2. domoneill
    06-27-2014 12:58 AM - permalink
    domoneill
    Disco Mike
    You seem to be v knowledgeable on such issues- was wondering if you can advise before I take it to the garage

    I have a '99 D2 V8, 82000km, petrol only, no LPG.

    Just bought a nanocom evo and when I plug it in today for the first time its showing a constant misfire fault on cyl2, which I thought I first noticed 2 days ago. Its just been in for a service 2weeks ago during which I had new leads and plugs replaced both with performance versions from Paddock. The car ran fine until 2 days ago and I have done 500+kms since the service without problem.

    The fault codes are; PO 202, 300, 302, 1000, 1300

    I should add that during the service I also removed the central silencer with a straight through pipe, but didn't touch the cat, and fitted a performance filter.

    Any ideas welcome.
    [/img]
  3. swfqk6
    06-23-2014 05:15 PM - permalink
    swfqk6
    Disco Mike,
    The "Three Amigos" bypass how to link died and has been dead for a couple of weeks. I guess I shouldn't have put off making the fix. You know what happened/where a bootleg copy might be?

    Thanks. Weston
  4. tpdllc
    05-20-2014 04:57 PM - permalink
    tpdllc
    Hi Mike,

    Hope all is well. Haven't spoken to you in along time since my DII has been flawless. Until now!

    Water pump went bad and I replaced successfully. Other than that the occasional left front O2 sensor throwing a signal. 2 times over last 400 miles. Now the P1300' P0303, 305, 307 codes. I replaced the plugs, I already had 8mm STI wires and I cleaned MAF sensor. Started and sounded better but all 4 codes came right back up.

    Suggestions?

    Thanks, Tom
  5. LRE96disco
    05-03-2014 09:30 PM - permalink
    LRE96disco
    Hey Mike,

    you seem to be the most knowledgeable member on here, so i figured you would be able to answer my question. I can not for the life of me figure out how to edit my account information on this website. do you know if there is a way to edit my signature and change my username? if you could point me in the proper direction it would be greatly appreciated.
  6. JonHen
    03-11-2014 07:03 PM - permalink
    JonHen
    I just bought an 04 disco that in the 1 week of owning has already shown this not be an easy ride. I love the truck and what its capable of so I won't be giving up easily. It has 135k and I have no maintenance history. It's been neglected to say the least. Seems to run and drive fine other than the obvious smell of coolant and oil. A slight tick as well. My "mechanic" just replaced the thermostat after an overheating issue and claims all is well. My question to you where do I start ? Lol what basic maintenance issues would you tackle first? Plugs? Wires? Leaks? And btw my odometer flashes, whats up w that? I appreciate your time and have read several of your helpful posts so that's why I reached out to you first. Thanks again
  7. P38inLA
    02-24-2014 03:23 PM - permalink
    P38inLA
    Hello.

    For the last two or three weeks I have gotten the dreaded P0130 and P0150 faults. All four O2 sensors were finally removed over the weekend. The first two were removed a week prior to the last two. First I removed the front diver side then the back passenger side. Anyway, I got all four from Ebay. Here is the listening: Land Rover Range Rover Discovery Upstream Front O2 02 Oxygen Sensor Brand New | eBay. These sensors are not Bosch. Do you think these sensors will produce the fault?
  8. lunchbox12387
    01-29-2014 10:00 AM - permalink
    lunchbox12387
    Hello Mike. Need help with a problem. I just replaced the head gaskets on my 02 disco and now she wont start. Got fuel and spark. Anything you can think may be wrong?
  9. miami
    12-10-2013 07:53 PM - permalink
    miami
    Good evening, Mike. I've finally found the rear hub w/ the sensor and I am planning on replacing it soon. But, I've been reading while getting all I need to do it and I've found a threat where you mention what else to do when you replace the rear hubs. You mention something about a list of things to do as well. I need that list! I am planning on replacing the rotors (to DBA), brake pads (to Akebono), Stainless steel brake lines (all 6). I am not sure I got your email since the last time we spoke. Feel free to email me at: MiamiDadeCounty@hotmail.com
    Thanks!
    Ray Vega
    Miami, FL
    (305) 345 3315
  10. RangeRover03
    12-10-2013 11:28 AM - permalink
    RangeRover03
    Oh, and one other thing, I replaced the final stage resistor due to the front blower motor going out and checked all fuses inside and out to no avail. so I've now purchased a new front blower motor but haven't tackled tearing the dash out to install it yet because we have recently had an ice storm where I live so we've been dealing with a few other major issues because of that right now.....any short cuts or suggestions on things to be aware of before tearing into this one would be greatly appreciated too.

    Thanks,

    Ken

About Me

  • About Disco Mike
    Biography
    Retired Service Manager
    Location
    Denver, Colorado
    Interests
    Anything Off Road
    Occupation
    Auto Service Manager/Writer
    How did you find this site?
    friend told me
  • Signature
    Mike

    Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
    99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

    To DOWNLOAD the RAVE Manual, follow this link http://www.landroverresource.com/

    Rover Radio issues or IPOD Adapters http://home.valornet.com/splacket/index.htm


    Need Parts?
    paulgrant@mac.com or call 203-770-1699
    willtillery@roverguy.com or call 434-251-9331
    P.T. Schram 260-804-0458

    Lucky8, http://lucky8llc.com/
    British Parts of Utah, http://www.bputah.com/

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 01-24-2014 02:57 PM
  • Join Date: 08-11-2004
  • Referrals: 39

Friends

Showing Friends 1 to 10 of 44

Contact Info

Instant Messaging
Send an Instant Message to Disco Mike Using...
This Page
http://www.landroversonly.com/forums/members/disco-mike-46.html
Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 02:08 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.3.2
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
All content is copyright 2004-2008 www.landroversonly.com and its original authors. Land Rovers Only is in no way affiliated with Land Rover