Land Rover Forums : Land Rover and Range Rover Forum - View Single Post - ECU fan
Thread: ECU fan
View Single Post
post #1 of (permalink) Old 11-12-2014, 04:28 PM Thread Starter
scotth
Senior Member
 
scotth's Avatar
 
Join Date: Mar 2005
Location: south carolina usa
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
ECU fan

Hey guys, I just purchased an 05 Range Rover a few weeks ago. I'm not new to land rovers I have had a Disco II for about 11yrs. I have a question. Every time I get in the vehicle I hear a fan running. I believe it is the ECU fan that is located in the large black box under the hood. Should this fan run when the vehicle is off. When I get in the vehicle in the morning it is running. The other day it seemed like it didn't want to start because of a weak battery. I turned the switch off and tried again and it started right up. I have also tried to start it twice, and nothing happens. No starting sound at all. I turned the key off an tried again and it starts right up. I have also had the air suspension inactive fault and trans fail safe fault this week. I researched and found that both could be caused by low voltage from the battery. I think the ECU fan is draining the battery some. Has anyone else experienced this. Thanks in advance for the help.

99 Disco 2
Kinversand ACE and SLS with 18's
brushguard and 265/60/18's installed
Hood blackout kit
RTE 2 inch lift
Future Mods:
TJM winch bumper,roofrack
scotth is offline  
 
 
For the best viewing experience please update your browser to Google Chrome