blower fan not blowing! resistor? new fan? - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 03-31-2011, 01:38 PM Thread Starter
Member
 
Join Date: Mar 2011
Location: Ireland
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
blower fan not blowing! resistor? new fan?

Hello to all, solutions to our problem please shes a 1990' one ten county station wagon.
jitter Bug is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 04-01-2011, 01:45 PM
Premium Member
 
TerryS's Avatar
 
Join Date: Aug 2004
Location: Bloomfield, CT If I died today, I lived there all my life.
Posts: 3,321
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Are you refering to the heater blower? The switch is part of the air control, and is kinda cheesy. Since the motors rarely go, I'd pull your binacle and have a look at the switch.
TerryS is offline  
post #3 of 3 (permalink) Old 04-03-2011, 02:05 AM
Member
 
Join Date: Jan 2011
Posts: 88
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The obvious checked the relevant fuse?
Nero is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Defender

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
AC fan not blowing! Is my engine going to overheat? Disco Christian Discovery Series II 17 06-01-2011 12:30 PM
warm air blowing inside, even when fan is off gazzychaz Discovery Series II 5 05-18-2010 05:42 PM
HVAC heater fan resistor location on '95? HaroldC Range Rover Classic 4 01-19-2008 03:51 PM
Blower fan OkieRover Range Rover Classic 4 11-15-2005 02:56 AM
Fan fuse blowing on heater 719jak Discovery Series I 2 07-13-2005 11:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome