2010 LR2 Not starting - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-13-2017, 12:40 PM Thread Starter
Member
 
Join Date: Feb 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
2010 LR2 Not starting

has new battery and new starter, push brake and start button and nothing happens, anyone have any ideas what this might be. before it died completely, it was hestatining to start, and on last start it tried one time to start and nothing, had starter test and it was bad, change it and still nothing, in need of help ASAP, also will a dead key fob be causing this?
aaron1578 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-20-2018, 06:44 PM
Member
 
Join Date: Apr 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
sorry, not sure if anyone posted back to this, we had the same issue. ended up being the main wiring harness going into the back of the fuse box came loose.
Asdickenson is offline  
post #3 of 4 (permalink) Old 06-03-2018, 12:27 PM
Member
 
Join Date: Jun 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have this problem as well though 2011. Battery charged all electrical working but instruments light up a couple of clicks then die.
MatthewC is offline  
 
post #4 of 4 (permalink) Old 07-04-2018, 09:02 AM
Member
 
Join Date: Jul 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2008 LR2 not starting fix

Quote:
Originally Posted by aaron1578 View Post
has new battery and new starter, push brake and start button and nothing happens, anyone have any ideas what this might be. before it died completely, it was hestatining to start, and on last start it tried one time to start and nothing, had starter test and it was bad, change it and still nothing, in need of help ASAP, also will a dead key fob be causing this?
My daughter's LR2 was in and out of the dealer (fortunately under warranty) for the same thing. They replaced anything that was remotely related to it starting.
Then after the 5th time being towed and in the shop, someone called for corporate assistance. They recommended replacing the steering column. It seems there was some sensor welded to the column that couldn't be replaced as a single part. After replacing the column, the vehicle has now been fine for the last 100K miles.
idyntafier is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Freelander / LR2

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2010 lr2 hse aaron1578 Freelander / LR2 0 02-15-2016 08:03 AM
2010 LR2 is whining... I♥MyLR2 Freelander / LR2 0 07-27-2014 01:51 PM
2010 LR2 occasionally having trouble starting jmtitan10 Freelander / LR2 0 06-06-2014 07:01 AM
2010 LR2 Purchase C.Arata Freelander / LR2 2 01-22-2013 05:34 PM
New 2010 LR2 (3 Questions) WarrenJackson Freelander / LR2 6 10-25-2010 05:35 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome