Hard steering when turning left at low speed - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-11-2018, 02:30 PM Thread Starter
Member
 
Join Date: Sep 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hard steering when turning left at low speed

Looking for some help here... I have been searching the web for a few weeks now. I have a 2008 LR2. The steering is very very stiff when turning left (only left) at low speed. The power steering pump and the rack and pinion were replaced but the problem persisted. The steering is normal once the vehicle is moving more than 8-10 mph. I am thinking this is an electronics issue. I have the GAP IIDTool but there are no steering related codes. Any help will be greatly appreciated. Thank you.
Winternheimer1 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Freelander / LR2

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Disco with steering wheel shake when turning at speed renkema Discovery Series II 11 08-04-2016 10:29 AM
low idle, hard steering II_HacKs_X Range Rover Classic 0 10-31-2015 03:48 PM
Strange vibration when turning left at speed Puddles Discovery Series II 8 05-31-2011 06:08 PM
Squealing from front end at low speed/turning. hub?? Riflman Discovery Series II 0 04-27-2010 07:00 PM
Squeak from right front while turning left! troverman Discovery 3 / LR3 2 04-06-2009 08:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome