HEEELP! 2003 LR Freelander Accelerator Pedal Position Sensor Issues - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-20-2018, 07:08 PM Thread Starter
Member
 
Join Date: Oct 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question HEEELP! 2003 LR Freelander Accelerator Pedal Position Sensor Issues

I'm about to lose my mind with this thing.
At our shop, I have (obviously) a 2003 Land Rover Freelander. My boss said he was going to toss it, but I love Rovers, so he gave it to me to see if I could get the thing running.
So - first it would barely start. When I plugged it into the diagnostic box, there was a mountain of problem codes. So I cleared the whole thing because half of the codes were from sensors being pulled, things being tested, etc. After patching some vacuum line leaks, throwing a new throttle body and TPS in there along with a new MAF sensor - I finally got it "kinda" running. The standing issue at this point is that when the MAF is connected, the thing stalls out, but when I pull it's pins, it idles alright but doesn't stall out. It's not the MAF because I've plugged in 4 other MAFs and it does the same thing. I even considered the possibility that each new MAF was statistically impossibly broken so I tested each one by blowing the air hose across each one and I was getting perfect results when I graphed it out. So - the one code I am getting that seems to be in the middle of all of this is a problem with one of the tracks in my accelerator position sensor. When I graphed this, track 1 looked perfect. hung at near 0 at rest, and rose accordingly as I pushed the gas pedal down. Track 2 however, was just chaotically bouncing up and down whether or not I was touching the pedal. I have no idea why the MAF would have an effect here unless the accelerator position sensor's parity track (track 2) was somehow only taken into account when the MAF is giving an account of the air throughput. So - I'm not only stumped - but I'm completely blown away at the lack of information there is for this model, year, and issue. Whenever I search any of the professional database's we're subscribed to, most of them try to correct me and send me to info about the TPS for some *&## reason. When I try to find a replacement accelerator position sensor on any of the usual distributor's sites I get ( you guessed it) lists and lists of available Throttle Position Sensors instead. And not just that, but actually getting to the accelerator position sensor is turning out to be a nightmare. Apparently I have to completely disassemble my entire dash just to pull the pedal assembly.
So ...
If you have any info as far as the accelerator position sensor's parity track and the MAF problem - I'll love you forever
... and ...
If you know of a shortcut for getting the pedal assembly out without pulling the entire dash out, or know of a simple way to get the dash out - I'll love you forever twice!
Thank you for reading this ... please somebody know something
Much love!
Thomas Wright is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Freelander / LR2

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Accelerator pedal anbran Discovery Series II 1 10-14-2011 06:21 PM
Crank Angle Sensor same as Crankshaft Position Sensor ? DiscoIIDenver Discovery Series II 2 12-27-2008 06:17 PM
Accelerator Stuck need help TrogRover Range Rover Classic 0 08-05-2008 06:43 PM
Whistling/squealing coming from engine when accelerator is engaged nasa25 Discovery Series II 12 03-13-2008 05:33 AM
leaking accelerator pedal david1 Defender 3 02-12-2005 02:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome