09 Range Rover Nav ?s - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 06-22-2019, 07:44 AM Thread Starter
Member
 
Join Date: Jun 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
09 Range Rover Nav ?s

I have the west coast nav disc in the system ( I dont have the east coast yet) - when i remove it - the system says need nav disc. I insert the disc and it populates all the information - I can set the position with the map location and it works fine - sets destination screen comes up person talks and im on my way.

When i go the normal route of clicking "on road nav"and go to input address>Destination entry> address... i click that nothing happens, I click SOS nothing happens, POI nothing happens - the green boarded shows up then goes away.

i am thinking the reader is bad in the drive has anyone had this happen? I have not diagnosed yet I will work on that monday.

will changing the disc to east coast make a difference?
dastugatz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-25-2019, 07:35 AM Thread Starter
Member
 
Join Date: Jun 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Update iam replacing the gps unit trying a ebay one

when i removed the gps hardware the rest of the system would operate normally and the screen said gps not fitted.


I reached out to denso requesting repairs if anything happens with that i will update.
dastugatz is offline  
post #3 of 4 (permalink) Old 07-02-2019, 05:01 AM Thread Starter
Member
 
Join Date: Jun 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
have not heard back from the nav company yet - i replaced the nav unit and the new one seems to be working well.
dastugatz is offline  
 
post #4 of 4 (permalink) Old 07-02-2019, 09:51 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,572
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 180 Post(s)
Did you take pictures of the removal and installation? We would all like to see.
tyl604 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rovers Only General Forums > General Land Rover Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome