Radio isn’t working and not lite up - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-18-2019, 06:25 AM Thread Starter
Member
 
Join Date: Feb 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Radio isn’t working and not lite up

I took my Land Rover discover 07 to get detailed the other day and when I took it there the radio was perfectly fine no signs of anything wrong with it and then when I got it back the radio wouldn’t turn on, none of the lights are working or the buttons when I push on them the whole thing is like it’s just died ... I’ve checked the fuses behind the glove box and all seem ok, has this happened to anyone else before? I don’t want to take it into the mechanics if I don’t have to as I feel like it’s something minor and they will probably charge me an arm and a leg for it ... I’m hoping that maybe when it was getting detailed they pulled out a plug or something so if anyone has any advice we would really appreciate all the help we can get
Big truck is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-18-2019, 07:15 AM Thread Starter
Member
 
Join Date: Feb 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
I’m only very new to this so I’d be really greatful for any help
Big truck is offline  
post #3 of 4 (permalink) Old 02-18-2019, 07:48 AM
member
 
SafariDave's Avatar
 
Join Date: Feb 2008
Location: Brooklyn, NY
Posts: 1,739
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 132 Post(s)
Quote:
Originally Posted by Big truck View Post
I took my Land Rover discover 07 to get detailed the other day and when I took it there the radio was perfectly fine no signs of anything wrong with it and then when I got it back the radio wouldn’t turn on, none of the lights are working or the buttons when I push on them the whole thing is like it’s just died ... I’ve checked the fuses behind the glove box and all seem ok, has this happened to anyone else before? I don’t want to take it into the mechanics if I don’t have to as I feel like it’s something minor and they will probably charge me an arm and a leg for it ... I’m hoping that maybe when it was getting detailed they pulled out a plug or something so if anyone has any advice we would really appreciate all the help we can get
Probably Water ingress through cowl into wires. See if your Pollen filter is wet. If your cowl is warped it will let water inside cabin through the air duct and wet the cables. When it dries up it should come back.
We own 2 D3's/LR3's. They both had warped cowls I changed it on my NYC LR3 and put a pice of plastic taped to the duct leaving room for air, but not for water. On the LA LR3 I taped the warped part of the cowl to the windshield not to get water in.
For better results when we change the cowl on the LA D3 we will beed the cowl to the windshield.
Dave

The City is a Jungle.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Present Land Rovers
1999 LR Disco II SD7 White 150K miles 'The Beach Boy' (PR truck)
2005 LR3/ D3 SE 4.4 Bonatti 'Fancy Professor' (my girl's LA LR3)
2005 LR3/ D3 SE 4.4 Bonatti 'The Rhino'
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
(my NYC LR3)
De-tangoed Headlights, LR4 Style Grille, Dueler Alenza HL 255/55/19

Past Land Rovers
1999 LR Disco II SD Niagara Grey 'Old Rhino' 200K+ miles (Sold)
1991 Range Rover Classic Green 'The Turtle' 200K+ miles (Sold)
1988 Range Rover Classic White 'The Rust Bucket' (Sold)
SafariDave is offline  
 
post #4 of 4 (permalink) Old 02-18-2019, 07:48 AM
Senior Member
 
Join Date: Jan 2012
Location: Phoenix, AZ
Posts: 259
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Quote:
Originally Posted by Big truck View Post
Im only very new to this so Id be really greatful for any help
Just to be clear my truck is a '01 D2 but this sounds like a short or a bad fuse. When you take your truck to get it detailed, they usually put plastic around some of the fuse panels and the connections so they can high-pressure wash your engine bay. Sometimes as a result of this (or lack of doing such because they believe the covers that are in place are enough), water will get into some places where it shouldn't and sometimes it can short something out or even blow a relay or fuse. I'm not sure that's what you have going one but it does sound like it as I had this exact same problem happen to me. It ended up being a fuse under the hood.

I'm a novice at electrical and still learning but I hope that does help.

Michael
'01 LR Disco II SE7


R.I.P. - 99 LR Disco Series II

For Used RRC Parts: Paul Grant [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For Used Disco Parts: Abran Abeyta [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For New Parts: British Parts of Utah or Atlantic British [most will price match Lucky8]
masantschi is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rovers Only General Forums > General Land Rover Discussion

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Discovery 2 automatic m and s light flashing and won’t turn over Benholmes91 Discovery Series II 0 11-12-2018 06:09 PM
Problems with horn not working, and hazards not working. gtr Discovery Series I 1 07-24-2010 11:42 AM
2001 Range Rover Radio not working and no pixels from AC/Heat not lighting up umoms Range Rover P38, Mk III and Range Rover Sport 0 04-03-2008 03:28 PM
Dealer said the radio serial # isn't coming up? UsedBlue Discovery Series I 3 02-26-2008 10:56 AM
ABS and TC lite up Nitwit Discovery Series II 4 04-19-2006 03:23 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome