2007 RR: No lights in MOST fiber optic system plugs, stereo issues - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-07-2019, 06:47 PM Thread Starter
DSW
Member
 
Join Date: Jan 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Exclamation 2007 RR: No lights in MOST fiber optic system plugs, stereo issues

Unfortunately I have had issue after issue with my 2007 RR stereo.

Initially:

Stereo "dead," land rover locked screen. Installed MOST fiber optic loop device in place of Nokia bluetooth unit along with new logic 7 amplifier. SOUND! But still land rover screen locked. Worked for a month or so with good sound.


Now, flashing orange light is back on volume knob. No sound. Still land rover screen locked. BUT, now, in the driver side trunk, when I unplug the connection to the nav unit, amplifier, Nokia unit, etc: NO ORANGE LIGHTS in the MOST fiber optic cables. I was previously seeing orange light when I would unplug a unit.

What is the most common culprit of this? I am fairly well versed in this system now, unfortunately! Is this a "head unit" problem? How do I troubleshoot this, when the MOST fiber optic cables all appear "dead?" I don't think I can bypass any units when the cables don't make any "light."

Thanks so much.
DSW is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-09-2019, 12:04 PM Thread Starter
DSW
Member
 
Join Date: Jan 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Anybody with better knowledge than I on these stereos that can help?
DSW is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Range Rover P38, Mk III and Range Rover Sport

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
After battery disconnect - car no longer starts?? 2007 RR HSE doktorek Range Rover P38, Mk III and Range Rover Sport 1 11-06-2014 06:32 PM
Savini Carbon Fiber wheel on RR Sport Savini Wheels Wheels and Tires 0 04-06-2011 12:34 PM
No warning lights / No ABS - No TC Rover2 Discovery Series II 20 09-04-2010 05:18 AM
For those like me with RR:C Stereo Issues Alkanomlhned Range Rover Classic 0 10-02-2008 04:07 PM
First no interior lights now no dash lights either hamrendan Range Rover Classic 4 10-12-2004 10:55 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome