just bought the 2006 RRS with (many) faults - Page 2 - Land Rover Forums : Land Rover and Range Rover Forum
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 19 (permalink) Old 07-15-2019, 03:04 PM Thread Starter
very disco
 
reverendALC's Avatar
 
Join Date: Jul 2008
Location: seattle, wa
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
right, but from what i've read, the compressor will run for some time looking for a pressure increase. this compressor is shutting off almost instantly, and if the air lines were in fact plumbed, it wouldn't be enough time to generate pressure at all. on a few rare occasions, i've seen it run for up to 10-15 seconds, but the vast majority of attempts last 1sec or less.

if my darned foxwell would show up i would go pull codes right now. nanocom finally took my money for the EVO tool, but they won't ship until tomorrow and i'll be lucky to get it before the weekend, likely to see it next week.

2003 Disco 2 SE7 - going to be buried in it
2006 RR Sport HSE - project
1997 Disco SE - SOLD
2003 Disco 2 SE7 - SOLD
1995 Disco SE - SOLD
2001 Disco 2 SE - SOLD
Foxwell NT510, Nanocom EVO
reverendALC is offline  
Sponsored Links
Advertisement
 
post #17 of 19 (permalink) Old 07-15-2019, 04:13 PM Thread Starter
very disco
 
reverendALC's Avatar
 
Join Date: Jul 2008
Location: seattle, wa
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
blah. installed my new brake switch, that didn't help either hehe. it was a stab in the dark, but people report all sorts of wackiness when those are bad

2003 Disco 2 SE7 - going to be buried in it
2006 RR Sport HSE - project
1997 Disco SE - SOLD
2003 Disco 2 SE7 - SOLD
1995 Disco SE - SOLD
2001 Disco 2 SE - SOLD
Foxwell NT510, Nanocom EVO
reverendALC is offline  
post #18 of 19 (permalink) Old 07-15-2019, 06:30 PM Thread Starter
very disco
 
reverendALC's Avatar
 
Join Date: Jul 2008
Location: seattle, wa
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
ok so...

just about every module on the truck has a "lost comm" error. i'm assuming those are stored codes from a flat battery recently.

i cleared all codes from the air ride module and restarted the truck, and the only one that came back was C1 A35-01 Reservoir Valve

oddly though, now the truck seems to be locked in some security mode. it won't start, and when i turn the ignition on, the hazards flash. Attempting to access some modules gives a "security access failed"

I queried the BCM and got:
B1 B02-28/P Low Frequency Coil
B1 BA0-66/P Suspicious Starting Activity
B1 C57-14/P Unused Relay Drive

That happened to me before, I just disconnected the battery for a few min and everything was fine, so i'm not too worried about doing that again.

Before i cleared the EAS codes, it had everything in there... reservoir valve, pressure increasing too slowly, pressure increasing too rapidly, air supply, and "invalid data received from VDC module"

i found the master reset of all codes... it got them all except the EPB code, which won't clear for some reason. now the truck keeps going into some alarmed state. i give up for the night. going to mount up the new compressor tomorrow and plumb all the lines, probably replace the brake light bulbs and throw a new battery in just for shits.

2003 Disco 2 SE7 - going to be buried in it
2006 RR Sport HSE - project
1997 Disco SE - SOLD
2003 Disco 2 SE7 - SOLD
1995 Disco SE - SOLD
2001 Disco 2 SE - SOLD
Foxwell NT510, Nanocom EVO

Last edited by reverendALC; 07-15-2019 at 08:13 PM.
reverendALC is offline  
 
post #19 of 19 (permalink) Old 07-17-2019, 08:17 PM Thread Starter
very disco
 
reverendALC's Avatar
 
Join Date: Jul 2008
Location: seattle, wa
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
i think i've been looking through the wrong end of the telescope on this one...

i replumbed the new compressor and and got the same code regarding the solenoid valve.
downloaded some shop manuals and other resources, and they all say to replace the valve block, which i pulled apart and went through. the solenoid works, the diaphragm that it actuates works... the only thing i didn't test was the pressure sensor... but i wasn't receiving any pressure related codes.

i'm leaning toward computer issues now... i was able to snag a very nice workshop manual, but it's for RHD TD models... a lot of schematic and troubleshooting is good, but location of components not so accurate.

can anybody definitively state where the EAS computer is on NAS 2006 RRS 4.4 petrol?

2003 Disco 2 SE7 - going to be buried in it
2006 RR Sport HSE - project
1997 Disco SE - SOLD
2003 Disco 2 SE7 - SOLD
1995 Disco SE - SOLD
2001 Disco 2 SE - SOLD
Foxwell NT510, Nanocom EVO
reverendALC is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Range Rover P38, Mk III and Range Rover Sport

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome