2002 LR Disco 2 - Rough idle and Hesitating - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-15-2019, 07:37 PM Thread Starter
Member
 
Join Date: Apr 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2002 LR Disco 2 - Rough idle and Hesitating

Hi. I have a 2002 LR Disco 2 which has been idling rough and hesitating while driving. Seems like its lost power. This all seemed to happen overnight.
First replaced the spark wires - no change Recently went and got both the CAT'S changed out as they were rattling - both were completely melted out.
Right after changed out both the ignition coils. Now have changed out all four o2 sensors and the MAF sensor.
Still seems to be idling rough and hesitating while driving.
No coolant being lost Ö had the head gasket done a year ago.
Any help would be appreciative.....Thanks!
This is my second Disco. First one I had for 15 years with little problems but this one I cant seem to be able to fix.
Darrin McGillis is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-16-2019, 04:47 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,568
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 178 Post(s)
Two thoughts. The wires are really hard to get popped back onto the coils; are you sure they are properly seated on the coils? And the standard picture showing which wires go on which coil receptor is reversed (it shows a view looking forward from the front seat instead of looking back from the radiator toward the windshield). So it is easy to get the wires crossed up.

Are you sure the plugs are OK?
tyl604 is online now  
post #3 of 4 (permalink) Old 04-16-2019, 05:57 AM Thread Starter
Member
 
Join Date: Apr 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Im going double check today the those wires....
Darrin McGillis is offline  
 
post #4 of 4 (permalink) Old 04-16-2019, 05:42 PM
G4 Mike
 
strap302's Avatar
 
Join Date: Jul 2017
Location: Tulsa
Posts: 56
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Garage
Plugs and the plug gap would be worth looking at. I once got a bad set of new plugs.
strap302 is online now  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle cold start in P, rough running idle. Hamhockracer Discovery Series II 0 03-26-2019 12:37 PM
LR Discovery II rough idle jmcbghs2012 Discovery Series II 2 03-23-2016 07:20 PM
96 Disco starts; runs rough, idles rough, pops urgh! anotherlisa Discovery Series I 3 04-14-2011 07:19 PM
Overheating, Code 25, rough rough idle DiscoBenny Range Rover Classic 4 08-28-2010 02:17 PM
96 Disco ongoing stumbling or hesitating with the VSS plugged in Len Discovery Series I 5 08-28-2007 04:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome