2nd post. Holy heck you arenít gonna believe this noise - Land Rover Forums : Land Rover and Range Rover Forum
 1Likes
  • 1 Post By Robertsr2010
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 01-21-2018, 04:10 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
2nd post. Holy heck you arenít gonna believe this noise

Soooo I replaced the head gaskets. It took me two days. I labeled everything and followed rave specs. Finally got it back together. When it turned over. I had a high idle and a roar like Iíve never heard. Some smoke too. http://https://youtu.be/fHJf07OtQ2Y

Iím pretty ticked.
IvyBred likes this.
Robertsr2010 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 01-21-2018, 04:33 PM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,933
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 280 Post(s)
Garage
Look at the bright side ..... It fired right up

Sorry to hear of you difficulty

Your link comes up invalid

Step back take a few deep breaths, maybe try to find a few pictures of all the plumbing in rave or even on the web, see if anything looks different.
High idle sounds like an intake leak, gasket, hose idle speed control circuit etc.
Maybe even try posting a few pictures of anything that you are suspicious of.

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by redtruck12; 02-08-2018 at 05:46 PM.
redtruck12 is offline  
post #3 of 15 (permalink) Old 01-21-2018, 04:39 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Quote:
Originally Posted by redtruck12 View Post
Look at the bright side ..... I fired right up

Sorry to hear of you difficulty

Your link comes up invalid

Step back take a few deep breaths, maybe try to find a few pictures of all the plumbing in rave or even on the web, see if anything looks different.
High idle sounds like an intake leak, gasket, hose idle speed control circuit etc.
Maybe even try posting a few pictures of anything that you are suspicious of.
I hear you. But dang I’m tired. Lol.
Robertsr2010 is offline  
 
post #4 of 15 (permalink) Old 01-21-2018, 04:46 PM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,933
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 280 Post(s)
Garage
Got you video!
Sounds like a big exhaust leak but that will not cause high idle. Air injections?
Smoke from the tail pipe? or in the engine bay?
Good oil pressure?
Engine light on yet? Any codes?

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
post #5 of 15 (permalink) Old 01-21-2018, 04:48 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Quote:
Originally Posted by redtruck12 View Post
Got you video!
Sounds like a big exhaust leak but that will not cause high idle. Air injections?
Smoke from the tail pipe? or in the engine bay?
Good oil pressure?
Engine light on yet? Any codes?
Welll just saw that my sai pipe clean snapped off of one side of the engine. Could that be it...
Robertsr2010 is offline  
post #6 of 15 (permalink) Old 01-21-2018, 04:53 PM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,933
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 280 Post(s)
Garage
Yes quite likely and a good place to start.
Even as a temporary repair to confirm the improvement
Keep us updated

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
post #7 of 15 (permalink) Old 01-22-2018, 04:58 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Quote:
Originally Posted by redtruck12 View Post
Yes quite likely and a good place to start.
Even as a temporary repair to confirm the improvement
Keep us updated

Your update! Red truck I JV welded a piece of pipe in the crack and it stopped the noise. I then had the high idle. Throttle cables were mounted with no slack. Loosened them. Hugh idle gone. Now. P0101. Itís a pending code. Not showing up in the dash yet.
Robertsr2010 is offline  
post #8 of 15 (permalink) Old 01-22-2018, 05:33 PM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,933
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 280 Post(s)
Garage
Sounds like you are on the right track.
P0101 would be Maf performance BUT not necessarily a bad sensor considering everything that has been going on.

So idle speed is now corrected and exhaust noise is gone?

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
post #9 of 15 (permalink) Old 01-22-2018, 05:38 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Yes! Car is running well. Nothing strange. It’s actually running better than ever. The code has not registered with the CEL yet. But is pending on my guage.
Robertsr2010 is offline  
post #10 of 15 (permalink) Old 01-22-2018, 10:13 PM
Senior Member
 
Join Date: Dec 2015
Posts: 186
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by Robertsr2010 View Post
The code has not registered with the CEL yet. But is pending on my guage.
Does your device allow clearing pending codes? If so clear it unless you like to have it hanging in there.
......

2004 NAS Discovery SE - DD/Owner/Maintainer
number9 is offline  
post #11 of 15 (permalink) Old 01-23-2018, 06:40 AM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Yeah. Planning to do it this morning. Figured I’d get some guidance on first things to check in the event it sticks. Thanks for jumping in number 9. You were the one who got me headed in the right direction initially!
Robertsr2010 is offline  
post #12 of 15 (permalink) Old 01-24-2018, 05:13 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Next update.

No high idle
New secondary intake.

No check engine
No codes

Car is starting slow. Cranks but not starting up fast. Err err err err vroom

Happened while I was someplace already sense it was seeming my disco was going to be sweet to me. As I was driving back smelled some burning. Smelled like exhaust. Checked all bolts to manifold and under the car to cat. Everything was tight.

There does seem to be a whiteish powder on all exhaust. There also is a mysterious mist on my windshield after driving.

I’m about to trade her in if I can get her to run lol
Robertsr2010 is offline  
post #13 of 15 (permalink) Old 02-07-2018, 04:00 PM Thread Starter
Member
 
Join Date: Dec 2017
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Done. Done.

She’s all fixed up and ready to go!

Well sort of.

Need to fix my knock sensor that I stupidly smashed. Atlantic British videos were key.

I thought I had a slipped sleeve because I heard a crazy ticking. Turned out to be a hole in secondary air. Both pipes replaced.

My battery also died during this process which is why the car was starting so slow.

New gaskets in she sounds great and I am a happy 2001 Disco 2 owne again. At least for. Now. Red truck and number 9 thanks for the help. Your tips led me to the right place every time. Guys like you on this site are invaluable.
Robertsr2010 is offline  
post #14 of 15 (permalink) Old 02-07-2018, 04:30 PM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,933
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 280 Post(s)
Garage
Thanks for the update glad you were able to see it all through.

Mine seems to eat batteries too

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
post #15 of 15 (permalink) Old 02-08-2018, 02:35 PM
Senior Member
 
Join Date: Dec 2015
Posts: 186
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 32 Post(s)
Quote:
Originally Posted by Robertsr2010 View Post
Done. Done.

Sheís all fixed up and ready to go!
Good to hear you're getting things worked out.
......

2004 NAS Discovery SE - DD/Owner/Maintainer
number9 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List
redtruck12

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
What the Heck is that Gurgling, Gnawing Noise at Idle? CDAllenInc Discovery Series II 8 09-20-2013 03:15 PM
A 2nd. Must Read for Any and All Valve train noise Disco Mike Discovery Series II 4 02-22-2013 08:43 PM
growling noise when shifting from 1st to 2nd gear reberto Discovery Series I 3 03-20-2009 02:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome