A/C won't blow... - Land Rover Forums : Land Rover and Range Rover Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 08-06-2016, 03:14 PM Thread Starter
Member
 
Join Date: Aug 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
A/C won't blow...

I recently bought a 2004 Disco 2 and for the first week the A/C blew strong and ice cold, then on some forest roads one day the fan stopped working.
I checked the fuse and it was fine so after fiddling with the controls for a bit I just rolled with the windows down until it came back on. It lasted the rest of the day until it gave out right when I got home. Its been out ever since.
The controls come on and I can adjust everything just fine, I can hear the compressor kick on but the fan wont budge. I tried knocking on it to get it started and whatnot. I bench tested the fan and it kicked on fine. I swapped the fan speed resistor with one from another disco and it still didn't work. Nothing seems to work. I live in Texas where its normal for it to reach 105F midday.. Any help would be greatly appreciated.
parkerclegg is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 03-27-2017, 10:23 PM
Member
 
Brett James Futter's Avatar
 
Join Date: Mar 2017
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
@parkerclegg. Mate have you set the fan to full blast? It may be a blown resistor, when the fan is set to max it should bypass the resistor and you should get some nice ice cold air again. The resistor is found in the cabin in the foot well of the passengers side (I have a rhd model). It is quite a small box located quite high up toward the center of the panel. It's super easy to change. I had to change one in my truck recently and it's been a treat since. Hope that helps.
Brett James Futter is offline  
post #3 of 25 (permalink) Old 03-28-2017, 01:27 AM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,267
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
Rule out the power and blower relays, both near the fan, C901(power) and C153(blower) in the pic, also check voltage they both must have live on the light green/white wire in the plug and for the blower to work there must be voltage on the white/red wire of C153 and earth on black/red of C901....if no voltage there it's some wiring or contact issue on the feed path from F31 check connection in C0765 pin 1
Attached Thumbnails
Click image for larger version

Name:	C0765.jpg
Views:	87
Size:	121.3 KB
ID:	76113   Click image for larger version

Name:	C0901.jpg
Views:	93
Size:	96.8 KB
ID:	76121  

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
 
post #4 of 25 (permalink) Old 07-20-2017, 01:46 PM
Member
 
Brett James Futter's Avatar
 
Join Date: Mar 2017
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
You won't believe it..... I'm having the same friggin issue as Parkerklegg.
@sierrafery I did everything you mentioned and am getting 12V in all the places I'm supposed to. I have checked the resistor I have checked the fuses. Are there any relays that could affect the vent blower? I have pulled the blower motor and it tests fine. I have now given the blower motor to an aircraft avionics engineer and asked him to test it for me.

I can't see anything wrong with the system thus far..... any ideas.

Parkerclegg did you ever solve the issue?
Brett James Futter is offline  
post #5 of 25 (permalink) Old 07-20-2017, 02:26 PM
Rover-Holic and Admin
 
ArmyRover's Avatar
 
Join Date: Sep 2007
Location: Augusta, GA
Posts: 7,879
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
Check power coming from the fuse panel. They break down and loose power going to certain circuits and the blower is one of those circuits

1972 MGB
2006 Bonatti Grey LR3 Proud Rhino Bumper, Baja Rack and TF underbody skid plates almost 33's lol
2007 Chawton White LR3 Proud Rhino lift rods
1983 Trident Green 110, TerraFirma suspension, and bumpers
1991 Range Rover Classic Hunter Eastnor Green


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ArmyRover is offline  
post #6 of 25 (permalink) Old 07-20-2017, 05:10 PM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,267
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
+1^^^, if you've got 12V with connectors unplugged it's irrelevant, when the blower is connected the 12V drops under it's load cos it's bad contact, usually at the fusebox

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
post #7 of 25 (permalink) Old 08-29-2017, 05:29 PM
Member
 
Brett James Futter's Avatar
 
Join Date: Mar 2017
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks guys will have a look at that today.

Much appreciated. I'll let you know what happens.

Cheers
Brett
Brett James Futter is offline  
post #8 of 25 (permalink) Old 08-30-2017, 02:00 AM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,267
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
If the blower works well with direct feed get hold of a piggiback fuse, remove fuse F7 interior fusebox, put the piggiback instead and splice into the brown/red wire of C431, it appears in the second pic in post nr 3. If this way the blower will work you need another fusebox eventually if you are lucky it's a bad contact in the plug, C0584 - pin 2(brown/red wire)
Attached Thumbnails
Click image for larger version

Name:	C0584.jpg
Views:	60
Size:	126.2 KB
ID:	79418  

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
post #9 of 25 (permalink) Old 11-16-2017, 12:07 AM
Member
 
Brett James Futter's Avatar
 
Join Date: Mar 2017
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Like Magic that fixed it.

I made a Video of the procedure if anyone wants.
Link:

Hope that helps some other poor fellow!

Cheers again for all the help.
Brett James Futter is offline  
post #10 of 25 (permalink) Old 11-16-2017, 12:47 AM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,267
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
There is strong live in the cabin too C0028 pin 1(brown wire) no need to bring a wire from the engine bay
Attached Thumbnails
Click image for larger version

Name:	C0028.jpg
Views:	55
Size:	65.8 KB
ID:	81137  

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
post #11 of 25 (permalink) Old 09-11-2018, 02:50 PM
Senior Member
 
Join Date: Oct 2010
Posts: 487
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Ok, Sierra & Army pulling and reinserting the fuse worked for like a day.

Do I put a pigtail fuse into fuse #7 and splice the pigtail wire into the C0028 pin 1 brown wire
or
splice it into into the brown/red wire of C431 ?

thanks,
sobieski
sobieski is offline  
post #12 of 25 (permalink) Old 09-11-2018, 03:57 PM
Senior Member
 
Join Date: Oct 2010
Posts: 487
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
And I should say, as far as electrical goes, I am on baby-step Zero.

I tested the fuse #7 slot and got about 9 volts - what does that tell us?
sobieski is offline  
post #13 of 25 (permalink) Old 09-11-2018, 04:21 PM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,267
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
Quote:
Originally Posted by sobieski View Post
Ok, Sierra & Army pulling and reinserting the fuse worked for like a day.

Do I put a pigtail fuse into fuse #7 and splice the pigtail wire into the C0028 pin 1 brown wire
or
splice it into into the brown/red wire of C431 ?

thanks,
sobieski
Splice into C0028 -1 with a 30A in line fuse holder like in the pic, put a 30A fuse in it and splice with the other end into C431-2(brown red) and let F7 out


My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
post #14 of 25 (permalink) Old 09-11-2018, 04:47 PM
Senior Member
 
Join Date: Oct 2010
Posts: 487
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Nice.
REALLY appreciate your (and eryone else's) expertise & experience - for you, especially on the electrical.

Is the C0028 to C431-2 definite or do I need to test the relay's before I snip those wires?

Like I said, babystep Zero.
sobieski is offline  
post #15 of 25 (permalink) Old 09-11-2018, 11:27 PM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,267
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
As long as F7 made tricks i suppose the relays are OK so that bypass should fix things

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Please tell me what this is and if my front differental is going to blow blackpaw80 Discovery Series II 2 07-07-2013 03:48 AM
D2 Slider blow out sale! fivespddisco Land Rover Parts and Accessories 0 06-25-2012 05:36 PM
Detroit Locker Blow out fivespddisco Land Rover Parts and Accessories 6 02-08-2011 07:19 AM
Help Before I blow this thing UP!!!!!!!!!!!! jesuscowboy Range Rover Classic 14 08-24-2010 09:37 AM
Drivers Seat BLOW OUT!! biggdoggs1 Discovery Series I 8 08-05-2010 12:15 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome