D2 2001 21.000 miles - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 06-30-2010, 07:17 AM Thread Starter
Member
 
Join Date: Nov 2007
Location: Cooper City ,Florida USA
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
D2 2001 21.000 miles

My D2 2001 with only 21.000 miles, came up with code P0305, a misfire on cylinder #5. Changed plugs with the champion and changed wires with the Magnecor 8mm; fired it up and the D2 threw the same misfire code on #5, I tested the wire and no spark was jumping from that wire to #5 cylinder; could it be the coil pack is bad or the distributor? any help, any ideas would be much appreciated. Thanks.
flyboyaviator is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 06-30-2010, 07:49 AM
Senior Member
 
Join Date: Dec 2009
Posts: 1,254
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Did the misfire first come up before or after you changed wires?
Bosbefok is offline  
post #3 of 8 (permalink) Old 06-30-2010, 08:10 AM
Senior Member
 
DiscoDream2's Avatar
 
Join Date: Sep 2009
Location: Summit County - CO
Posts: 3,218
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Sounds like the coil pack if,,, two wires have been tested and the same result occured. Clear the codes and try a third wire..one from the old wires you know works.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DiscoDream2 is offline  
 
post #4 of 8 (permalink) Old 06-30-2010, 08:28 AM
Member
 
Join Date: Feb 2010
Posts: 99
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
21,000 miles!!! I think you should just sell it to me dirt cheap since it is a hopeless cause. Haha, just kidding. If you end up needing a coil pack, Roverland dismantles and sells used Disco parts. Check out their pricing before you plunk down a lot on a new one.

99 Disco II -Sold, but I miss it....
fourstrokin650 is offline  
post #5 of 8 (permalink) Old 07-02-2010, 01:31 PM Thread Starter
Member
 
Join Date: Nov 2007
Location: Cooper City ,Florida USA
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
That misfire came before the wire/plugs change. we tested a different wire to see if the #5 had any spark ant that was negative, all of the other wires were sparking real nice.
flyboyaviator is offline  
post #6 of 8 (permalink) Old 07-02-2010, 01:32 PM Thread Starter
Member
 
Join Date: Nov 2007
Location: Cooper City ,Florida USA
Posts: 39
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mot a bad idea, sometimes is like breaking a wall with the head.
thanks for the offer.
flyboyaviator is offline  
post #7 of 8 (permalink) Old 07-06-2010, 08:21 AM
Member
 
Join Date: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Any progress yet? I have the exact issue after replacing plugs and wires. Mine is a misfire on #4. Had to replace the wires since the one on #4 was faulty and was arching nearly all along the wire. My best guess is that the resistance change from arching fried that terminal on the coil. I ordered a single coil pack from Advance. Very much dreading replacing the pac, wires were difficult enough.
martinsthree is offline  
post #8 of 8 (permalink) Old 07-08-2010, 07:38 PM
Member
 
Join Date: Jun 2010
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I'll answer my post because I did it! Truck is running great now. The coil pack was the problem. I really wish I was that guy. The one who wants a big truck because I'm small with a complex. Next time I remove the intake Manifold, there is not much room back there to wrench. Couple notes if you try.
Replacing one of the two packs works, short term diagnosis only. If you replace the whole assembly you will need to remove the IM. I was able to take the one I removed out by wiggling it toward the passenger side. Of course the secondary air pipes were off.
1/4 inch drive(small is needed), universal adapter, 2 and 5 inch ext(3 and 5 would have been slightly more comfortable), and an 8 mm slim socket worked for me. All bolts on the coil pack are 8mm. Secondary Air pipe connection to the bracket is 10mm, bracket connects to the engine with 8mm.
I plan on having this great truck for some time, cause I luv it. Could everyone who succeeds at a task post how to and best practice? I will.
martinsthree is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
97 Discovery 169,000 miles LRDisco97US Discovery Series I 8 06-01-2010 08:32 AM
Maintance price for 36,000 miles CaliRover Freelander / LR2 1 01-24-2007 04:28 PM
What is a 89 RRC worth ? 90,000 miles Roadhound Range Rover Classic 2 11-03-2006 07:16 AM
57,000 miles guitar588 Discovery Series II 13 10-26-2005 08:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome