no power to fuel pump, and inertia switch problem - Page 2 - Land Rover Forums : Land Rover and Range Rover Forum
Reply
 
LinkBack Thread Tools Display Modes
post #16 of 62 (permalink) Old 10-04-2012, 01:21 PM Thread Starter
Member
 
Join Date: Sep 2008
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
checked and replaced the main relay, still nothing. does anybody have a link to the wiring diagram? i think my next step is to make sure the wires to the ecu are good?

2003 DII
2001 DII
1997 P38 Vitesse -gone
kingstonman is offline  
Sponsored Links
Advertisement
 
post #17 of 62 (permalink) Old 10-04-2012, 01:33 PM
Senior Member
 
hafaday's Avatar
 
Join Date: Apr 2009
Location: Richmond, VA.
Posts: 1,286
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by kingstonman View Post
checked and replaced the main relay, still nothing. does anybody have a link to the wiring diagram? i think my next step is to make sure the wires to the ecu are good?
Go here.. bookmark it.. download all the stuff for the D2 and have fun.

01 d2

Bill H.

The Rave on pdf's.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hafaday is offline  
post #18 of 62 (permalink) Old 10-04-2012, 01:40 PM Thread Starter
Member
 
Join Date: Sep 2008
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thank you that is very helpful.

2003 DII
2001 DII
1997 P38 Vitesse -gone
kingstonman is offline  
 
post #19 of 62 (permalink) Old 10-06-2012, 02:04 PM Thread Starter
Member
 
Join Date: Sep 2008
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
so still no luck. i just spent most of the day going through everything with a buddy that is very skilled working with cars and we cant get it to start.

we went through all the wiring and everything was checking out. the one we were a little unsure about was on the fuel pump relay. we got 12v from (65) and 5v from (66) (see attachment. is that normal?

then we also tried to get the engine to run by jumping the fuel pump. so i can get the motor to fire with starter fluid, but can not get the motor to fire/run with the pump running. any ideas? because i am running out.

thanks
Attached Thumbnails
Click image for larger version

Name:	Snapshot 2012-10-06 14-58-26.jpg
Views:	13552
Size:	65.4 KB
ID:	32316  

2003 DII
2001 DII
1997 P38 Vitesse -gone
kingstonman is offline  
post #20 of 62 (permalink) Old 10-11-2012, 07:02 AM Thread Starter
Member
 
Join Date: Sep 2008
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Well i still have not figured out the problem, i sort of put it on the back burner as i picked up an 03 black on black 4.6 HSE7 yesterday. i am in the process of transferring everything over to my new truck (rack, ladder, sliders, skid plates, diff guards, lift wheel/tires, stereo, etc...)

I am leaning towards the ecu as the injectors are not opening now either. as soon as im able to get everything swapped over im going to get my old disco down to the shop and taken care of so i can sell it.

I will update when i figure out what caused this problem.

2003 DII
2001 DII
1997 P38 Vitesse -gone
kingstonman is offline  
post #21 of 62 (permalink) Old 10-11-2012, 11:37 AM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,594
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
I can't remember did you reset the inerita switch and or by pass it, if it is acting up, the pump won't activate.




Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Rover Radio issues or IPOD Adapters
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



Need Parts?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 203-770-1699

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

British Parts of Utah,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Disco Mike is offline  
post #22 of 62 (permalink) Old 10-12-2012, 09:24 AM Thread Starter
Member
 
Join Date: Sep 2008
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
i did test the inertia switch, it was not triggered. i replaced it just in case, and i did try to by pass it.

here is a pic of my new truck too! i have moved the rack and ladder so far, sliders are off the old and just need to be installed. my plan was to get the suspension swapped today, but its raining.... so hopefully it clears up long enough for me to get something done on my day off!
Attached Thumbnails
Click image for larger version

Name:	IMG_0065.jpg
Views:	2318
Size:	164.8 KB
ID:	32346  

2003 DII
2001 DII
1997 P38 Vitesse -gone
kingstonman is offline  
post #23 of 62 (permalink) Old 10-12-2012, 09:40 AM
Member
 
Join Date: Aug 2012
Location: Orlando/Tampa, Fl
Posts: 52
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The new one looks better anyway

2003 Disco II
Custom front bumper, 2" Lift, Goodyear MTR Kevlar's Factory Rims painted Black and more miles then it should have!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
frankiels3 is offline  
post #24 of 62 (permalink) Old 10-12-2012, 12:54 PM Thread Starter
Member
 
Join Date: Sep 2008
Posts: 35
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
thanks, i will update a pic when i get everything swapped over. the new truck has sls, so hopefully this weekend i will be able to grab some stock springs and swap suspension with my other disco, then the wheels/tires, skidplates, diff guards and all my stereo stuff.

2003 DII
2001 DII
1997 P38 Vitesse -gone
kingstonman is offline  
post #25 of 62 (permalink) Old 01-02-2014, 12:24 PM
Member
 
Join Date: Jan 2014
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I am having the same problem with my 01 disco...how did you solve the problem with the fuel pump?
addeible is offline  
post #26 of 62 (permalink) Old 01-02-2014, 12:31 PM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,594
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
If you want to add onto this link, at least post all the specifics as to your vehicle, mileage, last tune up, ever replaced the CPS and what have you checked so far?




Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Rover Radio issues or IPOD Adapters
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



Need Parts?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 203-770-1699

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

British Parts of Utah,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Disco Mike is offline  
post #27 of 62 (permalink) Old 11-25-2014, 10:35 PM
Member
 
Join Date: Nov 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Ran into something that has to be related today.

2004 Disco, 179K miles (Wife's truck). Pretty well maintained.

Recent history leading up to today.

1. Original alternator went out about four months ago; I replaced it with a refurbished NAPA unit. All good until a week ago...

2. Wife was driving it last week and the disco just died on her. She was able to restart it and drive it straight to the local LR dealership. They said it would take them a week to get to it and they gave her a loaner. Yesterday, they diagnose the issue as a bad alternator. I told them I'd get a replacement from NAPA and install it myself. They sold us a new battery to get it back home. OK...

3. Got a new OEM alternator from NAPA and installed it this morning. New battery and alternator - GOOD!

4. Driving up to Tahoe this afternoon in stop and go traffic, I noticed hesitation when I stepped on the gas from a stop - I actually thought I may have had my foot on the brake and gas at the same time (big boots). A few minutes later, same thing, except this time I got a "Service Engine Soon" and flashing green "M" and "S" gear symbols and flashing "D" gear indicator next to odometer. Pull off the road, shut it down and pulled the key out of the ignition. I start her up a few moments later and all lights reset except for the SES one. All seems fine.

5. I stop in Auburn for dinner about an hour later. Parked on a medium incline (nose up) and let the disco sit for about an hour. After dinner, I try to start it and it will only crank - not fire. Plenty of juice, cranking well. Called AAA and started to Google the issue on my phone. Checked all battery and alternator connections - they looked good. Phone died - last resort = look at the manual. I came across the Inertia Fuel Shutoff Switch and figured I'd give it a shot. I pressed on the rubber switch button (reset?) and she fired right up. Ran fine for the next hour all the way to Tahoe. We'll see how she does in the morning.

No door lock or flasher actuation, just fuel shutoff.

Any thoughts?

Thanks!
Tony Luna is offline  
post #28 of 62 (permalink) Old 11-26-2014, 08:50 AM
Member
 
Join Date: Nov 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Fired right up this morning...
Tony Luna is offline  
post #29 of 62 (permalink) Old 11-26-2014, 03:33 PM
Member
 
Join Date: Nov 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The plot thickens...
Tony Luna is offline  
post #30 of 62 (permalink) Old 11-26-2014, 04:01 PM
Member
 
Join Date: Nov 2011
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
The plot thickens...

Same sequence of events today. At highway speed, a jolt/hesitation followed by flashing dash lights. This time I noticed I was stuck in 4th gear when I pulled off the road. Shut her down, pull the key out, restart, all good again.

Stop for about an hour, and she only cranks - will not fire. No problem, I think, just reset the Inertia Fuel Shutoff Switch like last night. Didn't work. I pull the plug to the switch and jump it with a paper clip. BOOM! Fired right up again. Cool! Bad switch, right?

About 5 minutes into the drive, another hesitation followed by a complete shutdown - WTF!!! I'm sure this is what happened to the wife a week ago (bad alternator - I think NOT). Shut her all down, she starts right up. What gives???

Gurus, I need some insight. Help!!!

Thanks!
Tony Luna is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Inertia Switch ducmed Discovery Series II 19 09-21-2011 07:39 PM
Bypassing the Inertia switch skippermccoy Range Rover Classic 2 12-17-2007 07:36 PM
1990 Inertia Switch MuddyRangeRover Land Rover Parts and Vehicles Wanted 1 10-29-2007 05:07 PM
92 V8i (Dual Fuel) - How to replace the fuel pump? AND an LPG problem... Please help! chrismillard Discovery Series I 3 05-01-2006 04:39 PM
Inertia Switch? Toddicus Discovery Series I 1 11-14-2004 08:56 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome