Very Bad oil after the engine overhaul - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 01-29-2019, 09:13 PM Thread Starter
Sand fan!!
 
Join Date: Jun 2009
Posts: 39
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Very Bad oil after the engine overhaul

Hi, after I was having low compression in cylinders 8 & 6 I went for full engine rebuild... new: Rings, bearings, lifters, Sparks&wires, oil pump and high lift camshaft 53231.

I have the following issues since the first start till now ( ~ 1500 km):

- rough idle... The exhaust sounds crazy.
- oil turn to dark black very fast.
- high oil evaporation from pcv.
- multiple missfire on diagnostic.
- very high fuel consumption 30L/100km.

I have done a compression test for all cylinders and it was 150 psi +/- 5psi.

I've test the intake manifold for any leak by spilling some water.

Recently the back crank seal start to leak oil while I cancel the pcv and had an oil catch can.

I've tried to make the spark plugs with narrow Gap but no effect.

What you think I should do??
mshawari1 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 01-30-2019, 05:15 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,554
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 178 Post(s)
What year and model?
tyl604 is offline  
post #3 of 13 (permalink) Old 01-31-2019, 11:37 PM Thread Starter
Sand fan!!
 
Join Date: Jun 2009
Posts: 39
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by tyl604 View Post
What year and model?
2004 Discovery 4.6 NAS
mshawari1 is offline  
 
post #4 of 13 (permalink) Old 02-01-2019, 06:36 AM
Senior Member
 
Join Date: Jan 2012
Location: Phoenix, AZ
Posts: 259
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Quote:
Originally Posted by mshawari1 View Post
2004 Discovery 4.6 NAS
Who did the rebuild for you?

Just to make sure we understand fully, are you saying the truck was running fine, aside from the low compression in 6 & 8, prior to the rebuild and now it's doing all of the above?

Michael
'01 LR Disco II SE7


R.I.P. - 99 LR Disco Series II

For Used RRC Parts: Paul Grant [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For Used Disco Parts: Abran Abeyta [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For New Parts: British Parts of Utah or Atlantic British [most will price match Lucky8]
masantschi is offline  
post #5 of 13 (permalink) Old 02-02-2019, 05:39 AM Thread Starter
Sand fan!!
 
Join Date: Jun 2009
Posts: 39
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by masantschi View Post
Quote:
Originally Posted by mshawari1 View Post
2004 Discovery 4.6 NAS
Who did the rebuild for you?

Just to make sure we understand fully, are you saying the truck was running fine, aside from the low compression in 6 & 8, prior to the rebuild and now it's doing all of the above?
The rebuild was done in-house with help of experience mechanical engineer. The rebuild kit from victor*REINZ expect one ring from britpart as we break it. Connection bearing was replaced. But other crank bearing was not changed since we didn't remove the block from*the car ... No honing ... Old pistons used.

No smoke comes from the exhaust so far ... I feel some pressure from crank ventilation over the valves cover
mshawari1 is offline  
post #6 of 13 (permalink) Old 02-03-2019, 03:50 PM
Rover-Holic and Admin
 
ArmyRover's Avatar
 
Join Date: Sep 2007
Location: Augusta, GA
Posts: 7,884
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
He wasn't that experienced.

There are so many things that could have gone wrong with your "rebuild" that I don't really know what advice to give. Good Luck

1972 MGB
2006 Bonatti Grey LR3 Proud Rhino Bumper, Baja Rack and TF underbody skid plates almost 33's lol
2007 Chawton White LR3 Proud Rhino lift rods
1983 Trident Green 110, TerraFirma suspension, and bumpers
1991 Range Rover Classic Hunter Eastnor Green


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ArmyRover is offline  
post #7 of 13 (permalink) Old 02-04-2019, 06:35 AM
Senior Member
 
Join Date: Jan 2012
Location: Phoenix, AZ
Posts: 259
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Quote:
Originally Posted by mshawari1 View Post
The rebuild was done in-house with help of experience mechanical engineer. The rebuild kit from victor*REINZ expect one ring from britpart as we break it. Connection bearing was replaced. But other crank bearing was not changed since we didn't remove the block from*the car ... No honing ... Old pistons used.
I'm with ArmyRover on this one - there are so many things that could have gone wrong on your rebuild and if it was not acting like this beforehand, process of elimination says the rebuild either was done incorrectly OR reassembly was performed incorrectly. It sounds to me like you need to start tearing it apart from the top down to try and figure out where your problem is.

Sorry

Michael
'01 LR Disco II SE7


R.I.P. - 99 LR Disco Series II

For Used RRC Parts: Paul Grant [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For Used Disco Parts: Abran Abeyta [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For New Parts: British Parts of Utah or Atlantic British [most will price match Lucky8]
masantschi is offline  
post #8 of 13 (permalink) Old 02-04-2019, 07:40 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,554
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 178 Post(s)
Yes. I realize that is bad news but I agree. Something wrong with the rebuild.
tyl604 is offline  
post #9 of 13 (permalink) Old 02-04-2019, 10:08 AM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,945
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 281 Post(s)
Garage
Seems to me it is inaccurate to call what was done a “rebuild”
Not even out of the truck??? I guess that’s why the mains were not done. It may have had some repairs but surely this cannot be considered a rebuild.
Back to square 1 on this one I’m afraid.

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
post #10 of 13 (permalink) Old 02-04-2019, 08:51 PM Thread Starter
Sand fan!!
 
Join Date: Jun 2009
Posts: 39
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Okay guys ... Guide me to the inspection steps. I would like to check if the cam alignment if it is correct. I'm planning to remove the valves cover and check if the cylinder no.1 valves are fully closed at TDC . Will but a screwdriver into plug hole to know if its at TDC. What you think?

Any other suggestions?
mshawari1 is offline  
post #11 of 13 (permalink) Old 02-05-2019, 05:40 PM
Rover-Holic and Admin
 
ArmyRover's Avatar
 
Join Date: Sep 2007
Location: Augusta, GA
Posts: 7,884
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)
My guess, due to the lack of honing the rings haven't seated properly. With the rings not working as planned you get blow bye. Blow bye will cause nasty looking oil, oil consumption and excessive crankcase pressure.

1972 MGB
2006 Bonatti Grey LR3 Proud Rhino Bumper, Baja Rack and TF underbody skid plates almost 33's lol
2007 Chawton White LR3 Proud Rhino lift rods
1983 Trident Green 110, TerraFirma suspension, and bumpers
1991 Range Rover Classic Hunter Eastnor Green


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ArmyRover is offline  
post #12 of 13 (permalink) Old 02-09-2019, 08:09 PM Thread Starter
Sand fan!!
 
Join Date: Jun 2009
Posts: 39
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Update ...

There is small carnk case pressure.

I've visited two specialist:

The first one said it's due to slight miss alignment of the camshaft. But I can't see any indication of that.

Second one said it's due to wrong installation of ring with two cases .. a) flipped top ring, b) broken ring during the fitting.


What you think?
mshawari1 is offline  
post #13 of 13 (permalink) Old 02-09-2019, 08:36 PM
Moderator
 
redtruck12's Avatar
 
Join Date: Jan 2013
Location: cambridge ontario canada
Posts: 1,945
Mentioned: 3 Post(s)
Tagged: 1 Thread(s)
Quoted: 281 Post(s)
Garage
If it’s not apart it’s all just speculation.

Happy Happy Happy

2002 D2 se7 6 seater . complete engine rebuild with flanged liners , 2 inch lift, terrafirma shocks, LT 275/65r18 Cooper stt tires, d1 modified front bumper, safety devices rack, 30" l.e.d. Light bar
2004 D2 se5 (sold)
2001 D2 se5 (parts truck)
2000 D2 se7 (retired)
1997 D1 (sold)
1957 Series 1 88" future projet
2006 Suburu legacy outback (gets me around when the disco is not)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
redtruck12 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
AUX input is very very low sound volume cvtech Discovery 3 / LR3 11 12-15-2010 08:38 AM
Something very very wrong... PSM General Land Rover Discussion 2 02-01-2010 07:38 PM
Bad Amp...Bad Amp...Bad Amp... coldfrez Discovery Series II 2 05-20-2009 04:27 PM
Help my rover leaks like a sieve after overhaul owenslabounty Series Land Rovers 2 05-20-2009 03:34 PM
Hard Gear Shift After Transfer Case Overhaul royemaun Discovery Series I 2 08-20-2005 07:10 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome