warning lights, m and s flashing and engine - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-10-2009, 12:42 PM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
warning lights, m and s flashing and engine

Hi,

I recently had a problem with my 2000 model disco 2, whilst on the freeway felt like a gear change then the M and S lights flashing and the engine light on but the engine was still running and no throttle. Please assist.

Daren
Durban
RSA
papayyad is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-10-2009, 01:50 PM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,594
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
You need to better describe what is happening.
How old is your battery, are the cables clean and tight? When did you last service your tranny?
Low voltage can cause this to happen, might want to go have your battery/alternator tested and let us know what the voltage is.




Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Rover Radio issues or IPOD Adapters
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



Need Parts?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 203-770-1699

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

British Parts of Utah,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Disco Mike is offline  
post #3 of 6 (permalink) Old 07-11-2009, 02:51 PM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Hi Disco Mike,

I could not drive the vehicle because of no throttle. Vehicle starts with no problem hence I think the battery is fine. I had to truck the vehicle back home. Light on the dash m,s and d flash and also D on the gear. Also engine stall light is on although engine is running. Thanks for your response.
papayyad is offline  
 
post #4 of 6 (permalink) Old 07-11-2009, 02:54 PM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Mike, I have the vehicle for 7 months only, not sure how old the battery is. Tried to check the cables but in a very difficult position.
papayyad is offline  
post #5 of 6 (permalink) Old 07-11-2009, 03:15 PM
Administrator
 
Disco Mike's Avatar
 
Join Date: Aug 2004
Location: Denver, Colorado
Posts: 16,594
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
What do you mean by it has no throttle, be alot more specific.




Mike

Retired service manager, member of Solihull Society, SCLR, NCLR and the Santa Barbara 4Wheelers clubs.
99 D2, 3" lift, CDL with Detroit,T.T. lockers, 4:11's,H.D. axles, custom ft/rear bumpers with sliders, a 9500 HSI Warn winch and 5 HID's.

To DOWNLOAD the RAVE Manual, follow this link
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Rover Radio issues or IPOD Adapters
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



Need Parts?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 203-770-1699

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or call 434-251-9331
P.T. Schram 260-804-0458

Lucky8,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

British Parts of Utah,
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Disco Mike is offline  
post #6 of 6 (permalink) Old 07-20-2009, 09:15 AM Thread Starter
Member
 
Join Date: Jul 2009
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
hi Mike,

Replaced the electric accelerator pedal and problem solved. Cost almost R3000
papayyad is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series II

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Any body doing electric hybrid in a LandRover? Adam in NYC USA Hybrid 57 12-03-2010 12:33 AM
Check Engine Flashing... MARGRETTE Discovery Series II 10 03-26-2009 07:04 AM
sport/manual lights and drive indicator flashing worldrover Discovery Series II 7 03-24-2009 07:11 AM
P38 ..Non-Starter!! Fozzy Range Rover P38, Mk III and Range Rover Sport 25 04-12-2006 02:50 AM
Custom fabrication people.. I have a pair of turbos 02disco2 Discovery Series II 9 01-24-2006 06:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome