2008 LR3 DVD not Working - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-21-2019, 07:33 PM Thread Starter
Member
 
Join Date: Jan 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2008 LR3 DVD not Working

I have a 2008 LR3 with a factory DVD set up. About a week or so it has stop working. I can hear the sound but no video. The only video I see is the black screen with white lines, the same video output is seen in the back monitors. Any ideas what it might be? I have cleaned the DVD player with a DVD cleaner.
desertfoxh is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery 3 / LR3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2008 LR3 Keyless Entry Not Working KyleSC Discovery 3 / LR3 5 08-25-2018 11:25 AM
08 LR3 DVD Changer Not working + Fixed drmich Discovery 3 / LR3 0 08-21-2015 06:37 PM
2008 LR3 power seats just stopped working pepbrow Discovery 3 / LR3 0 02-02-2013 08:33 PM
Problems with horn not working, and hazards not working. gtr Discovery Series I 1 07-24-2010 11:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome