Radio Volume...Water? - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 05-09-2019, 10:01 AM Thread Starter
Member
 
Join Date: May 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Radio Volume...Water?

Long story short...


06 LR3 HSE. Radio volume works 20% of the time. Comes on randomly. When it's not working, it's almost like the radio doesn't even recognize the knob - it doesn't say "Audio Volume" or show any of the volume numbers like when it's working.

Pooling water in passenger footwell. I have replaced passenger sunroof drain, warped windshield cowl and blew out both AC drains. It's drying out slowly.

Question...could the water be affecting my intermittent volume issue or does that sound amp or software related?
06LR3HSE is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-17-2019, 07:23 PM
Member
 
Photoguy's Avatar
 
Join Date: Feb 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
I'm surprised nobody replied, this is pretty common. I also have an 06, my experience is the water. I'll say 99% chance, yours is water as well. I know you replace the drain tubes, but they still periodically get clogged. Just need to poke down there with something, to clear out.

You could pour a little water down the sunroof drains (driver & pass), you'll know right away if it's clogged, should spill out somewhere in interior.

2006 LR3 V6 162,000 miles
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Photoguy is offline  
post #3 of 6 (permalink) Old 06-18-2019, 05:02 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,607
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 191 Post(s)
Water may very well be your problem. My DII got wet at the front windshield and the radio stopped working; would not change channels and volume would play but not adjust up or down. It dried out and has been fine since.
tyl604 is offline  
 
post #4 of 6 (permalink) Old 06-25-2019, 03:17 PM
Member
 
Join Date: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
any resolution to this? i'm having the same problem. head unit does not recognize volume knob- so no sound. happened when i tried to use the aux jack. didn't have any issue before doing that. ugh
errol is offline  
post #5 of 6 (permalink) Old 06-27-2019, 07:25 PM
Rover-Holic and Admin
 
ArmyRover's Avatar
 
Join Date: Sep 2007
Location: Augusta, GA
Posts: 7,894
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
There can also be water intrusion on the A Pillars due to leaks at the trim clip holes.

I cheated and drilled holes in the rockers to allow them to drain if there are leaks in the future

1972 MGB
2006 Bonatti Grey LR3 Proud Rhino Bumper, Baja Rack and TF underbody skid plates almost 33's lol
2007 Chawton White LR3 Proud Rhino lift rods
1983 Trident Green 110, TerraFirma suspension, and bumpers
1991 Range Rover Classic Hunter Eastnor Green


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ArmyRover is offline  
post #6 of 6 (permalink) Old 08-31-2019, 11:33 AM
Member
 
Join Date: Jan 2009
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
any fix?
errol is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery 3 / LR3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Range Rover HSE Radio Volume pulses on and off rgrimes007 Range Rover P38, Mk III and Range Rover Sport 0 01-03-2013 12:43 PM
Radio help,no rear speaker volume!! morreale5 Discovery Series I 2 04-03-2012 06:18 PM
Inexplicable drop in radio volume Leaks Discovery Series I 7 09-17-2010 07:54 PM
Radio Volume is suddenly very low/quiet abqpatch Discovery Series I 2 03-21-2009 06:38 PM
Radio works, but can't turn up volume! (P38) troverman Range Rover P38, Mk III and Range Rover Sport 5 11-29-2005 05:27 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome