Radio works, but no Sound out of speakers? - Page 3 - Land Rover Forums : Land Rover and Range Rover Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 32 (permalink) Old 05-09-2019, 01:04 PM
Senior Member
 
Join Date: Jan 2012
Location: Phoenix, AZ
Posts: 271
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 59 Post(s)
Quote:
Originally Posted by 06LR3HSE View Post
Not revive a dead thread, but I figured someone stumbling across this might be able to point me in the right direction...

06 LR3 HSE. Radio volume works 20% of the time. Comes on randomly. When it's not working, it's almost like the radio doesn't even recognize the knob - it doesn't say "Audio Volume" or show any of the volume numbers like when it's working.

Pooling water in passenger footwell. I have replaced passenger sunroof drain, warped windshield cowl and blew out both AC drains. It's drying out slowly.

Question...could the water be affecting my intermittent volume issue or does that sound amp or software related?
Post #16 of this thread sounds like the same thing you are experiencing. They posted the solution as well.

Michael
'01 LR Disco II SE7


R.I.P. - 99 LR Disco Series II

For Used RRC Parts: Paul Grant [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For Used Disco Parts: Abran Abeyta [
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
]
For New Parts: British Parts of Utah or Atlantic British [most will price match Lucky8]
masantschi is offline  
Sponsored Links
Advertisement
 
post #32 of 32 (permalink) Old 05-09-2019, 06:36 PM
Senior Member
 
bbyer's Avatar
 
Join Date: Sep 2008
Location: Edmonton Alberta Canada
Posts: 649
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
hard reset first

See my post above, #24 regarding how to do a hard reset.

It costs nothing, damages nothing, and sometimes fixes the radio.

You problem sounds a bit different is that I guess you do have sound/music but at a low level?

If so, maybe the hard reset will not work as for me, I get no sound a all, usually after a battery change out or new alternator being installed - something that totally depowers the 3 for awhile. I think it might be caused as a result of disconnecting the battery before the truck has gone to sleep and hence the audio software or whatever gets corrupted.

The hard reset seems to straighten that out, or whatever.

As I said, costs nothing and does not wreck anything and might solve the problem. If it does, let us know. I guess let us know regardless.

Water and the wires never seem to mix well.

Water collects in the under door sill channels and takes months to dry out but I do not think any audio system wires are there - mostly under the carpet thru the centre console and in the doors to the speakers.

That said, I also like the post #16 solution where the those wires are under the edge of the carpet and parallel the drivers door sill channel.

2005 LR3 HSE 4.4L V8 petrol; Traxide dual battery kit; Rear Cargo area LED lighting; PIAA 2500K H11 Yellow Ion fog light bulbs; Patch cellular antenna to underside of interior of glass roof; CounterAct LT-2 capacitive corrosion control system; LLumar AIR80 Blue Low E clear Infra Red heat reducing side window tint; Manual upper rear door cable release; Schrader valve "air in" mod to OEM air tank; Akebono ceramic pads on OEM solid vented rotors; LR4 hitch receiver; Wiggs D4 Bluetooth Module; 3 Blink signal light feature; Clock on the Dash; D4 Backup Camera; 2015/16 Nav Data update.

Last edited by bbyer; 05-09-2019 at 06:41 PM. Reason: post #16 comment
bbyer is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery 3 / LR3

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 4 (1 members and 3 guests)
Photoguy
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio works but can't hear sound anngybee Range Rover P38, Mk III and Range Rover Sport 8 01-29-2010 04:38 PM
94 LWB Radio Question - No RH Sound christof Range Rover Classic 2 06-08-2009 11:42 AM
Replaced radio but still no sound (has power, though) flyfishinbum Discovery Series II 3 02-16-2009 10:09 AM
My speakers and sound system are very poor. Got any tips on decent speakers>? kylehaz1 Freelander / LR2 2 11-23-2005 07:35 PM
Rear speakers don't sound right rsholanki Range Rover P38, Mk III and Range Rover Sport 0 01-27-2005 07:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome