radio is off but static comes through spreakers Any thoughts? - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-15-2016, 10:44 AM Thread Starter
Member
 
Join Date: Mar 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
radio is off but static comes through spreakers Any thoughts?

When it is wet outside, the radio on will occasionally get lots of static which will continue if the radio is turned off. Also with the radio on no sound will come from the speakers. Happened once after going through car wash and today when it was raining.
Could it be a faulty amp? Other thoughts? Thanks
Jim Sloman is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-10-2016, 07:02 AM
Member
 
crazyguy's Avatar
 
Join Date: Feb 2016
Location: west palm beach, fl
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Mine did that when I went through too deep of a puddle and got water in the radio housing. I'm guessing you have a short in the doors near the speakers. what year is the truck?
crazyguy is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Range Rover Classic

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
radio static? bb4wheels Discovery Series I 11 05-03-2012 07:12 AM
Radio Static bhanderson9 Discovery Series I 25 11-10-2011 12:18 PM
Radio static/poor reception.... NHDORY Discovery Series II 2 08-11-2008 11:45 AM
Radio static!!! mac55 Discovery Series I 1 07-24-2008 11:52 PM
Radio static mac55 Discovery Series I 10 08-15-2006 05:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome