2011 LR4 HSE Thermostat/Cooling System Problem - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-26-2019, 07:43 AM Thread Starter
Member
 
Join Date: Mar 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
2011 LR4 HSE Thermostat/Cooling System Problem

Hello. I'm not a "CAR PERSON", so I'm going to try my best to properly explain my issue, so please bear with me. I have a 2011 HSE with about 120K miles. I have been living a coolant system NIGHTMARE! I noticed a coolant leak (puddle on the ground) and took it in to get looked at. The mechanic found the leak and from that has subsequently replaced my water pump, radiator coolant hose (it burst!), thermostat, viscous fan clutch, and various coolant hoses. A small leak has since been found in my radiator, and before I spend another dime I need to know what is going on.

I have owned my vehicle for 5 years now and it "feels" to me to be a pressure issue. The latest thing that was done was bypassing the thermostat. The water still didn't bleed all of the air out the line. It acted as if something was blocking the flow of the water. After bypassing the thermostat, the radiator was removed from the vehicle and we ran a water hose through all ports and could not find any obstructions, thus ruling out the radiator. Brand new thermostat, water pump, fan clutch, hoses, and belts.....still overheating and rough idling(limp mode)... I'm at a complete loss.

Prior to this, I had not been putting the correct antifreeze (green) in my car. Since all the work, I have (pink). I have read the correct coolant is a HUGE FACTOR in my coolant system running properly.

Please Help.
Jacqueline Grant is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-26-2019, 06:20 PM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,605
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 191 Post(s)
Are you showing codes?
tyl604 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Land Rover 4 / LR4

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 19" Land Rover LR4 HSE Wheels and Tires For Sale dalharrma1 Wheels and Tires 0 05-11-2017 05:47 AM
2011 19" Land Rover LR4 HSE Wheels and Tires For Sale dalharrma1 Land Rover Parts and Accessories 0 05-09-2017 11:00 AM
Installed 180f thermostat in place of 192f thermostat gurunutkins Discovery Series II 33 09-01-2016 06:43 PM
98 p38 4.6 HSE cooling system issue? NE DISCO II Range Rover P38, Mk III and Range Rover Sport 1 03-06-2011 04:48 PM
to thermostat or not to thermostat... Soulman Discovery Series I 10 11-10-2010 06:25 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome