Bogging sputtering and back firing - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-12-2018, 06:46 PM Thread Starter
Member
 
Join Date: Nov 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Bogging sputtering and back firing

I just bought a 96 discovery started driving home and about 40 miles in it started bogging and sputtering and backfiring when I push the throttle won’t rev up but idles fine when I let it cool off it drove fine another 30 miles did this 5 times to get it home and while running tests and trying to find solution it continues the same symptoms when it’s good and warm any help I’m stumped
Anthony Batista is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-13-2018, 04:52 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,572
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 180 Post(s)
I had these symptoms on my '99 DII when I changed plugs and wires. Turned out that I got some of the plug wires crossed on the coil pack. That is a really difficult thing to trace but is a thought. Except that mine missed and backfired immediately, not after warming up.
tyl604 is offline  
post #3 of 3 (permalink) Old 11-14-2018, 04:36 PM Thread Starter
Member
 
Join Date: Nov 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I checked that and it was not the issue I have a mass airflow code and a engine coolant temp to low for closed fuel loop code but would like to see what your guys thoughts were before I go buying a bunch of expensive parts
Anthony Batista is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sputtering and stalling CurvyRover Range Rover Classic 16 03-14-2018 11:58 AM
bogging down llomo000 Discovery Series II 3 05-10-2013 02:34 PM
Stuttering, bogging down at idle kcabpilot Discovery Series II 3 12-05-2012 06:03 AM
mud bogging, how to waterproof? Amclutch Range Rover Classic 0 03-16-2010 06:52 PM
Engine bogging down going up-hill... Kickdown problem? DashfaceDisco Discovery Series I 16 04-16-2009 06:29 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome