Drivers side window does not open with warm weather - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-13-2019, 05:03 PM Thread Starter
Member
 
Join Date: Jan 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Drivers side window does not open with warm weather

Hi,

I have just purchased a 1998 Discovery and the drivers side window does not open when the outside temperature rises. When it cools down it is fine.

Has anyone heard of this issue and how it can be tackled?

Thanks

Tony
Tony Bianco 030809 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie, with question on the drivers side floor leak and drivers window inoperable Glen Clark Discovery 3 / LR3 3 06-23-2017 04:16 PM
03 LRD - Drivers side window not funtioning jaymooges Discovery Series II 3 01-14-2016 01:39 AM
00 Disco 2 drivers window and Sunroofs wont open BCU? Short? -Jesse- Discovery Series II 4 08-12-2015 11:16 AM
Drivers side a/c blows cool(not as cold as it did) but passenger side blows warm air Binggg Range Rover P38, Mk III and Range Rover Sport 1 04-08-2013 09:15 AM
Poor idle after warm weather restart...misfire riemer Discovery Series I 0 01-27-2007 06:12 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome