Looking for advice on something??? help - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 09-05-2005, 01:28 PM Thread Starter
Member
 
Join Date: Aug 2005
Location: Hummels Wharf Pa 17831
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question Looking for advice on something??? help

Hi all i am looking for advice on my electronic fuel injection control unit. here is what i did as a test and i want to make sure this is the problem? Well my passenger side cylinders were not getting any fuel so in terms the injectors were not working or putting fuel in the cylinders. So what i did was take my new injectors and test them on the other side to make sure they were pulseing like they should and they did but on the passenger side i got nothing so this tells me they are not putting fuel into the engine. either the wiring is dead or something like that but i did a test on the wiring itself and it tested ok???? so i am running on 4 cylinders lol right now. Does anyone have any ideas of what is the problem?? Could it be the electronic fuel injection control unit or is it something a little simpler then that?. plain in simple i am not getting any fuel on the passenger side of the engine. help plzzzz. before you all ask the timing is correct,there is spark, the fuel pressure is good, just not giveing any fuel on that side at all. i am gonna be drinking allot of beer after this is done with heheh.

Thank you
George
krigtt198 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 09-05-2005, 04:13 PM
Senior Member
 
DISCO INCUBUS's Avatar
 
Join Date: Aug 2005
Location: NEW YORK CITY
Posts: 229
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Fuel Injection

Your still having the same problem with this beast ,huh.
You say fuel press, spark,timing,injector wiring is ok.
If you suspect the pass side injectors are not getting fuel, with engine off
pull out the injectors from the rail and you should see some fuel come out
if it is dry you must have a blockage in the rail on that side. If fuel is in the
rail, i would recheck the wiring to that side, you say there is voltage to that
side, is it pulsing?. I would use a noid lamp.

I am convinced, these trucks are possessed.



Why wait till it's done DRINK NOW i do
DISCO INCUBUS is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome