No power at all - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-10-2019, 07:06 AM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 14
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
No power at all

Good day my 98 4.0 V8 Disco 1 is completely dead, no cranking, no cabin lights, nothing . I wondered, could a fried ECU cause such a thing? I have checked the other probable causes, battery, alternator, starter, along with the wires. I am at my wits end, any suggestions?
roverfox9 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-10-2019, 08:35 AM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,331
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
For such blackout first suspect is the fusebox

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.
sierrafery is offline  
post #3 of 6 (permalink) Old 04-12-2019, 04:45 AM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 14
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Found the problem, thank you .
roverfox9 is offline  
 
post #4 of 6 (permalink) Old 04-12-2019, 05:22 AM
Senior Member
 
tyl604's Avatar
 
Join Date: May 2008
Location: Atlanta
Posts: 1,572
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 180 Post(s)
Would help all the rest of us if you could post what you did to resolve the problem. Others may have this same problem in the future and would like to know what to do.
tyl604 is offline  
post #5 of 6 (permalink) Old 04-12-2019, 12:19 PM
Senior Member
 
sierrafery's Avatar
 
Join Date: Oct 2015
Location: Transylvania
Posts: 1,331
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 246 Post(s)
OMG, maybe it's a secret

My friends call me Fery

2000 Discovery Td5 ES manual

Hawkeye v.6, Nanocom EVO,
VDM UCANDAS, oscilloscope


if you think my english is peculiar it means you didnt hear my japanese

ALL MY ADVICES ARE BASED ON MY OWN KNOWLEDGE AND MY WAY OF UNDERSTANDING THE DESCRIPTION AND OPERATION OF SYSTEMS... I'M NOT A LAND ROVER TRAINED SPECIALIST JUST AN ADDICTED ENTHUSIAST.

Last edited by sierrafery; 04-12-2019 at 07:11 PM.
sierrafery is offline  
post #6 of 6 (permalink) Old 04-12-2019, 08:09 PM Thread Starter
Member
 
Join Date: Dec 2015
Posts: 14
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Just some corrosion in the main fuse box. Got it cleaned up now it works. Now on to the bloody high idle X(.
roverfox9 is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
06 lr3 base radio went completely off no power at all danvirues Discovery 3 / LR3 1 11-15-2014 06:33 AM
No Power to Fuel Pump, ? relay fine, no clicking noise under hood LRDisco97US Discovery Series I 11 05-28-2013 07:31 PM
power seat no power??? cedarjames Discovery Series II 2 09-22-2011 04:54 PM
No start, No power to fuel pump, ECU? Tiderover General Land Rover Discussion 2 09-17-2005 01:24 PM
No no no... you want this... darkknight1999 General Land Rover Discussion 1 08-31-2005 09:44 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome