No spark from coil - Land Rover Forums : Land Rover and Range Rover Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-23-2019, 08:02 AM Thread Starter
Member
 
donno's Avatar
 
Join Date: Oct 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
No spark from coil

95 Disco Standard

Any thoughts on no spark from the coil?

Seemed to happen intermittently and now won't start at all and have traced it to no spark. Been following the Rave troubleshooting and I've done the 4 voltages at the coil and they seem good. For test 3, amplifier switching, I'm getting 12 volts with the ignition off where it says it should be zero. I seem to remember that this test was an error in Rave manual so not sure on that? Can anyone confirm proper procedure?

I have already fitted new coil and amplifier. New wires, cap and rotor. Pickup in the distributor seems to have the correct resistance (3.5k ohms). I'm going to check the air gap and check the continuity of all the wires including the relocation wire for the amp. Anything else I can check?

Cheers
donno is offline  
Sponsored Links
Advertisement
 
Reply

  Land Rover Forums : Land Rover and Range Rover Forum > Land Rover Model Forums > Discovery Series I

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
95 Rover Classic 4.2 no spark at coil kiwii5858 Range Rover Classic 8 05-28-2012 08:46 AM
Help disco died today, no fuel pressure, no spark?? addam Discovery Series I 14 03-10-2012 06:45 PM
2003 Disco II No Spark, No Fuel, but cranks Jester01 Discovery Series II 3 05-02-2011 07:50 PM
no start will no spark. killthimall Discovery Series I 6 08-18-2009 07:49 AM
No Spark from Coil - Please help! mahi 1 Range Rover Classic 4 09-24-2008 08:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome