Land Rover Forums : Land Rover and Range Rover Forum - Reply to Topic
Thread: radio is off but static comes through spreakers Any thoughts? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-10-2016 07:02 AM
crazyguy Mine did that when I went through too deep of a puddle and got water in the radio housing. I'm guessing you have a short in the doors near the speakers. what year is the truck?
03-15-2016 10:44 AM
Jim Sloman
radio is off but static comes through spreakers Any thoughts?

When it is wet outside, the radio on will occasionally get lots of static which will continue if the radio is turned off. Also with the radio on no sound will come from the speakers. Happened once after going through car wash and today when it was raining.
Could it be a faulty amp? Other thoughts? Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome