Land Rover Forums : Land Rover and Range Rover Forum - Reply to Topic
Thread: Pillar Trim Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Land Rover Forums : Land Rover and Range Rover Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
09-02-2019 08:40 PM
Claus Hi Guys,

2 weeks ago I had my windshield replaced. I had the work done by a well known "franchise chain" at a local shop that showed a good rating on Google. They were also the only place who did not have to order the windshield in which was a surprise as I asked them for a specific brand. Well arriving at the shop they did indeed have a windshield in stock but not the one I was advised...long story short they replaced my windshield as it had a "hole" in it. All seemed okay until 2 days ago when on the highway doing 70 mph I hear a pop and see the right A-pillar trip flapping in the wind only held on by the hood. I pull over bewildered of seeing this, look at the . trip and learn that ALL but 1 of the retainer clips are either snapped on half or mangled from what seems to be repeated pounding on the trim with the clips not being aligned to match up with body holes.....

I still have a strong urge to pay the shop a visit and express my opinion about this in a manner that will leave a decade long impression but why waste the energy. Instead I left them a "good work" google rating.

SO, right now I am on a quest to replace the grey duck tape patch job by replacing the retainer clips. I have looked on eBay and Amazon and while I have found what appears to be "OEM" or similar the asking price is just horrendous; From $49 Cad for 6 (plus shipping) to a whopping $23 US for one !!!. Based on this I am thinking that I will try to find a non-rip-off but decent quality alternative. Any suggestions?. I have tried to find the size that will fit but have some up emtpy handed so far..

Any advise is greatly appreciated !

Claus
01-30-2019 11:59 AM
ArmyRover jb weld would be a fairly permanent solution I guess. I didn't see any good spot for that to be honest
01-29-2019 07:59 PM
Brian Anderson Question.. I just had the same problem on my LR4.. I was told to replace the clips only..but noticed that there is a adhesive patch.. I was thinking of using JB Weld on it to re-seal it tight.. with only the clips..I can still hear it being slightly loose.
09-18-2017 08:07 PM
CoopLR3 I replaced some of those clips with near fits too, last week. I added new rubber washers to prevent water in the A pillar and replaced the patch for the lower peg. There's a TSB on it. "LA501-006 A pillar water leak"
09-18-2017 06:41 PM
ArmyRover Me to, tired of buying trim pieces that fell off lol
09-18-2017 05:36 AM
slowLR3 Glad you didnt lose it on the road flying off !
09-17-2017 11:32 AM
ArmyRover
Pillar Trim

So I was driving back from South Carolina yesterday when I heard a loud pop. I looked over and saw my pillar trim flapping in the wind through my passenger side window.

Pulled off and took a look to find 3 clips had snapped. In case you have never had the pleasure of driving minus this trim it is amazing how much wind noise it creates. It's like you left a window open.

So today I got a chance to mess with it and I went to advance auto and picked up some clips that looked close. I had to trim them just a bit and they were a tight fit in the trim piece, but they got the job done.

Now it looks better and more importantly its quiet inside again.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome