Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
While driving on cruise control, my vehicle lost power, would not take throttle. Pulled over and vehicle would idle but not take throttle. Turned off and it would not restart. Pulled codes and they were lean (p0171,174); i assume not getting fuel. Checked inertia switch and it wasnt thrown. Swapped relays and would not start. When i got home (towed) i jumpered the relay and i got the vehicle to start; seemed to take a while to pressure up the fuel header but would not stay running. It would accept throttle inputs, but would pop back through throttle body (like it was choking). pulled codes and got p1230--i think it means that there is an issue with the fuel pump. I'm going to check for power to the fuel pump when i get home today. Anyone have any insight?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
While driving on cruise control, my vehicle lost power, would not take throttle. Pulled over and vehicle would idle but not take throttle. Turned off and it would not restart. Pulled codes and they were lean (p0171,174); i assume not getting fuel. Checked inertia switch and it wasnt thrown. Swapped relays and would not start. When i got home (towed) i jumpered the relay and i got the vehicle to start; seemed to take a while to pressure up the fuel header but would not stay running. It would accept throttle inputs, but would pop back through throttle body (like it was choking). pulled codes and got p1230--i think it means that there is an issue with the fuel pump. I'm going to check for power to the fuel pump when i get home today. Anyone have any insight?
Bump
 
1 - 2 of 2 Posts
Top