Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I had this really nice long message but something killed it so this time to the point. 04 RR with 105,000. Read out clean but a few days after wife driving I drove it to ball tasks with oldest daughter. Told her severasl times on freeway shifting isn't right. Feels like its stuck in 4th gear. When we can out of the game running lights were on. Can't tell how long but long enough. Truck still cranked sand drove home. Later that night oldest girls took it out and got stuck. Only park and any other gear was like neutral. To clarify I could move shifter but it would not engage in any gear except park. Tried several things that night and Sunday sent back. I noticed 5 amp fuse in 37.but truly can't remember if I did it sat night. Tried resetting through many procedures online. 37 in crank, turn off and remove. Steering all left then all right, after 2 mins disconnect batt and hold po neg together and ever hold gas pedal down while on off trick. Basically anything I could find online but regardless of shifter I have park or neutral only. I can hear the ecu going thru shifting gears but trasns does not engage. Next is check trans fluid and Li es for blockage. PLEASE ANY ONE HELP. Any other tricks I can try to at least get rover in my driveway. PLEASE.
 

·
Registered
Joined
·
33 Posts
Your 04-HSE, as mine, are built by BMW, the transmission is sealed and you cannot check it as the conventional cars, it has to be checked by the dealer from underneath. I don't see the connection between you in disconnecting the battery... I have not heard of this before. I am sending you a link that might help you out.
MkIII L322 Range Rover Remedies. I wish I could be of more help . Where are you located?
Cheers
Lou
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top