Land Rover and Range Rover Forum banner

1 - 8 of 8 Posts

·
04 D2
Joined
·
4 Posts
Discussion Starter #1
Hey fellas, I recently picked up a 2004 SE. Not knowing the last time the oil was changed and after a bit of research here on the forum, I decided to go with the Rotella T 15 40. After a 20mi drive, I noticed a lot of lifter tick, then at a stop light the oil indicator started flashing. Has anyone got any ideas? Is this normal for Discoveries? The only thing that I did was a basic oil change, with a wix filter. Thanks for any input.
 

·
Premium Member
Joined
·
16,594 Posts
Stop driving it if the oil light is coming on.
How mechanical are you?
Once you get past this problem, you might want to read and do the entire major service list posted at the top of this section.
 

·
04 D2
Joined
·
4 Posts
Discussion Starter #3
EHi Mike, thank you for the reply. I am very mechanical, I've restored other brit classics (Jensen, TVR, Triumph, austin) , this also isn't my first 4x4. I stopped driving her, shes sitting in the driveway. I was half a block from the garage thank god. Prior to the oil change, I went thru her and changed out the filters, plugs, plug wires(8mm), flushed the coolant, inspected the belts and hoses, etc... Everything is within specs or new so this is sort of confusing. I've never had an oil light come on AFTER an oil change.

I forgot to add, that in neutral the light doesn't blink. Only under load and only stopped. The pump appears to be functioning correctly.
 

·
Super Moderator
Joined
·
2,164 Posts
Listen to mike gunner
I'm a mechanic with 25 years general repair experience and mike astounds me with his knowledge and experience with these machines
 

·
Premium Member
Joined
·
16,594 Posts
The oil light comes on at around 6 pounds pressure, not surprising it goes off when in neutral, RPMs go higher.
If you want some help with this PM me your number and I'll be glad to walk you thru a lot of possibilitys including a broken oil pump gear.
 

Attachments

·
04 D2
Joined
·
4 Posts
Discussion Starter #7
Ok, so apparently the only service the previous owner didn't have done at the dealership was anything involving fluids... I changed the oil a second time and the Rotella T I put in 2 days before was almost black. After the second change the valvetrain chatter is almost gone and the oil lamp hasn't came on. Looks like I'm in for an oily weekend, lord knows what the other lubricants look like...
 

·
Premium Member
Joined
·
16,594 Posts
That being the case, might want to check my major service list at the top of this section for a guide what needs to be done.
 
1 - 8 of 8 Posts
Top