Land Rover and Range Rover Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1995 Disco 1 with rebuilt motor-heads replacement etc. Vehicle cranks up with very rough idle, running only on 4 cylinders drivers side. Just installed new fuel injectors, power to injectors seems to be good from wiring harness, 32 -34 psi on fuel rail, spark from new wires and plugs but fuel injectors seem to not be receiving signal to distribute fuel. My guess anyway. Any ideas on problem? Could it be bad ECU? If the ECU is bad will it still run on 4 cylinders? Any help would be greatly appreciated.
Thanks
 

·
Administrator
Joined
·
2,423 Posts
Sounds like injector control the way I read it.
How did it run before the engine work?
 

·
Registered
Joined
·
16 Posts
G`day ,

I didn`t read the heading you do say pass side , so you`ll look at pin 11 YW .

The ECU uses pin 11 AND pin 13 to alternately earth each bank .

Pin 11 uses YW yellow/white to earth cylinders 2 , 4 , 6 and 8.

Pin 13 uses YU yellow/blue to earth cylinders 1 , 3 , 5 and 7 .

The main relay , pin 87 power all the injectors via NO brown/orange .

If it runs on one bank you`ll have power to all eight injectors because it uses one wire the NO .

You should be able to check the continuity of the YW and YU wires by un pluging the ECU and check that the ECU pins 11 and 13 are earthing .
 
  • Like
Reactions: redtruck12
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top