Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 1996 Land Rover Discovery. Over past few months a vibration started while driving and has worsened. Idle is perfect, not in steering, not tire issue, and I am pretty sure it does'nt have anything to do with tranny actually shifting gears. I feels like a miss fire while driving from 5mph to 50 when put under load. It is like a shuddering not violent but definately noticeable, it is not ,however ,noticable at over 50mph. When gas pedal is pressed on take off or inbetween shifts up to hwy speed there is when it is most pronounced. All 8 cyls are firing normal.

Anybody got a clue what it might be? my local dealer is a little $cary So i appreciate any help i can get. I love this crazy thing! Our dirt road can be rather treacherous during wet times of year and we used to get stuck 6 to 10 times anually and now i find myself dissappointed if there is no cumbersome slop to navigate. Thanks Dan
 

·
Registered
Joined
·
229 Posts
sounds like the flex disc to me...its basically a big piece of rubber that connects your driveshaft to the rear diff...sit underneath the truck and have someone rock it back and forth with the truck in park you will see it move...if you need further help ill get you a picture of what im talking about...those basically get shot and warn out and crack and viberate like sonofabitch
 

·
Registered
Joined
·
70 Posts
have the swivel preload checked... my Disco shook violently from 60-70mph, not all the time though, random days... swivels loosen up over time, some come from the factory loose like that, got mine fixed for $550 by a LR mechanic, private garage
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top