Land Rover and Range Rover Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey guys, my 1987 range Rover will not start. Found I had a bad glow plug so I replaced all of them. Had to remove a fuel line to get to one of them also. Put it back together and no start. Bled it at the fuel filter, lift pump, Injection pump and injectors. All have fuel coming out with no air present. No smoke out the pipe when cranking. BTW I could not get Bosch glow plugs but bought from a reputable rover dealer in UK. Thanks for any help, it's killing me, lol.
 

·
Premium Member
Joined
·
1,509 Posts
Hi. Rule out the crank sensor or related wiring/plug
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Found out 3 of the 4 "new" glow plugs I put in it have high resistance, and don't glow with 12 volts applied
New ones should be installed friday
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Update,

New glow plugs arrived. Also found connector to fuel cut out switch was busted. Must have hit it while removing glow plugs. Fixed that, and installed new glow plugs and it fired up. Ran at a idle but anything above would make engine stall. Now won't restart. Gonna have to take a serious look at fuel pressure and volume. Any other diesel owners on here?
 

·
Rover-Holic and Admin
Joined
·
7,895 Posts
Very few sadly they really didn’t offer the diesel much in the states
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Sorry guys, i wanted to update thread. I replaced fuel line from lift pump to HP pump and it started. Must have been sucking air. Now i have a possible head gasket problem. Want to do a leakdown test, should i pull injector or glow plug for the test?
Thanks
Kevin
 
1 - 6 of 6 Posts
Top