Land Rover and Range Rover Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Hi,

I have a 2003 Disco and when I start it, sometimes the Manual and Sport (M) and (S) lights flash and it drives very sluggish. It goes out after 3-6 restarts. The dealer changed the battery but it's still happening? anyone have this problem. The dealer says they have never heard of this.
Thanks
 

·
Super Moderator
Joined
·
828 Posts
I had it happen once on my Disco2. It happened after I washed it, after I restarted the vehicle, it never came back on. This was 10K miles ago. There weren't any fault codes stored either.
 

·
Registered
Joined
·
121 Posts
jarover said:
Hi,

I have a 2003 Disco and when I start it, sometimes the Manual and Sport (M) and (S) lights flash and it drives very sluggish. It goes out after 3-6 restarts. The dealer changed the battery but it's still happening? anyone have this problem. The dealer says they have never heard of this.
Thanks
This is a very common problem,it can be caused initially by starting the engine and engaging D or R too quickly. It would normally register a fault message along the lines of "can timeout error",all this means is a gear is selected before the engine management has been able to determine gearbox status and it gets itself all confused bless it.Under these circumstances the gearbox goes into a fault mode.The only other thing I personally have found is a poor connection where the multi-plug connects to the auto box.If the pins in this plug are ok,I would suggest making sure there are definitely no error messages within gearbox or engine management and ensure you allow a few seconds between start up and putting it in gear and see how it goes.
Mick.
 

·
Registered
Joined
·
8 Posts
S&M Lights

This sounds so familiar. I have had this problem on my 99 disco. Found out to be a fault with the alternator and earth lead. After changing the battery a few times and then the alternator the problem was fixed with a new earth cable on the alternator.
You would think the dealers would talk with each other to solve these common faults instead of trying to invent the wheel all the time.
 

·
Registered
Joined
·
23 Posts
Blinking M and S

Ok, I know that this is an old post but, I just ran across it. I had that one time, right after I got my DII, turned it off then on again, never came back. I leafed through my manual, it is listed there, it's a tranny/transfer case thing. I do believe the previous posts were correct that engaging the tranny too soon after start will do that. Nothing serious, unless it's always on.
 

·
Registered
Joined
·
363 Posts
Aloha!

It must be nice to get the M on the dash board! I have had my truck for a year and the only time I see the M is when I start the truck. I would ask the stealership, but I know it would be a wast of my time.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top