Land Rover and Range Rover Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello!

My 2004 LR Disco (88,000 miles) is having issues starting. It all started about a week ago... I've had the car for about a month and there were no issues prior to then. What's happening is when I turn the key to position I, all the electrics come on as they should and same as position II, but if I leave the key at either position the electrics will go in and out as seen by the radio and dash lights. When I turn the key all the way to start it, nothing happens at all. The dash lights and radio will turn off when I turn to position III, and there will be no cranking, no clicking, nothing. When I go back to the other positions, the electrics will work fine (Well, coming on and off) again. Sometimes the electrics will stay on though, so I'm not sure what that means. In addition, the horn won't work at these times and the key fob has issues locking and unlocking the car.

Typically the issue resolves itself within a few minutes, but today it hasn't yet so I'm growing more concerned. When I do get the car started, everything is fine! This doesn't even happen all the time either, maybe every couple days or so, and like I said it usually fixes itself.

Any ideas on what could be the issue/ what I should replace/ a way to get around the problem until I get the right part in?

Thank you!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Also, so far the only thing I have done to try to resolve this issue is clean the corrosion off of my battery (the positive terminal was pretty bad) but that obviously didn't help anything.
 

·
Registered
Joined
·
1,506 Posts
Bad battery, not enough juice to turn starter, maybe???? Did you test voltage on battery?
 
1 - 3 of 3 Posts
Top