Land Rover and Range Rover Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys so here is my problem I own a 2006 Range Rover Sport Supercharged and I just started to have the following problems. Bare with me I broke up the description into two parts since I eventually got it to start and run but then had the same problem again and I know how dfficult it can be to diagnose like this.

Part I.
I started it cold yesterday and it ran fine as usual. I reversed out of my driveway and when I put the shifter in drive it acted like it was in neutral. I sat there for a minute and double checked to ensure it was in drive which it was. I then put it back into park when several faults started to pop up to include the following "Transmission fault","HDC fault", Parking brake release fault". It was still idling fine but now its stuck in park. I decided to shut it off and restart. As soon as I shut it off it would not turn over again, nor could I get it out of park to even push it off the road. The first thought was a low battery so I had a passing neighbor jump me off. The jump worked and it started so I put it into drive and back into my driveway I went. I waited 5 minutes and then reversed once again and the same thing happened when I put it back into drive. I left it for two hours since I had court and when I returned home It started up no problem only now the check engine light was on. I took it for a test drive and it was fine, it went into boost, and shifted smoothly. I decided at that time it was low battery so I parked it for the night and put the battery on a charge.

Part II.
I let the battery trickle charge overnight and when I woke up today my charger was flashing red which means a bad battery. I tried to start it anyway but the iginition just comes on along with all electronics and fault codes but it will not crank. There is an audible clicking noise in the glovebox every time I turn the key. ("relay or solenoid"?) I took the battery to advance auto and had it tested it said it was fine which I believe since it is not even a year old purchased it in Nov, 2014. So now the fact that all electronics still worked in the car makes sense its obviously not a battery problem. Now I am totally lost as to what it could be. I read several forums with similar issues like being stuck in park but I dont understand the parts people are referring to like "IP" or a bad"con bus". It is not a reverse light switch plus none of those issues had fault codes like mine. The only thing I also found out was a leaky sunroof causes something to corode? I know mine leaks into the drip drains but I didnt think it was an issue Where does the water go and what does it corode? Thanks to anyone who takes the time to read and respond to this the nearest dealer is an hour away and how would it even be towed being stuck in park.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #2 ·
I see no replies yet so I will post what I have found out thus far in case anyone has a similar problem. I went through every wiring harness and connector I could reach and sprayed it with WD-40 to expunge any moisture. As I was going through the wires I pulled the three plugs from the transfer case control module directly behind the battery tray to find it was heavily corroded. I cleaned it up with a soft brush and put it back together. I did not find any further evidence anywhere of corrosion. I hooked the battery back up to try it one more time and it started and drove no problem. I shut it off and restarted it a few times before leaving my driveway. took a 200 mile trip with it over the weekend with no issues. Today I was driving and out of nowhere I get stuck in 3rd gear. No response in manual mode and eventually once the RPM's hit a little over 4000 it shifted and was ok the rest of the drive. No fault codes or further issues. Now I am really interested in what this further issue could be. Is the transfer case control module even something that would prevent the transmission from shifting as it did at the beginning of my problem last week?
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top