Land Rover and Range Rover Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I bought my LR2 used, from the second I got it I had to start fixing things, My first issue was starting the car, and it is still an issue! I've replaced fuel pumps? Injectors? --- I know nothing about auto care, anyhow something was wrong in that area, they also did some kind of system update, as I left the dealer I nothced my car was having issues and I ended up having to go back and get another update, that one worked for awhile until a week later when I found out I needed an ac compresser that no Land Rover dealer had in the states so I had to wait a month without my car for the part to get here, they also fixed something else-- like I said I know nothing about cars, I've also had to put new break pads and rotors on, okay so THEN ,I thought everything was going to be good after a fee thousand dollars, but nope I couldn't get the car to start after I had filled up at the gas station, my husband jumped me and we went and bought a new battery, my car was starting like a champ until two days later I went to start it and nothing, just a little click and the lights came on that's it, so now my car is getting towed to dealership. I don't understand these starting issues? They checked everything the first time around and fixed a few things, I don't know if I need another system update but that would call for 3 in 9 months and i think it will be crazy if i have to deal with this on a regular basis considering the updates are pretty expensive for just a little tech thing, does anyone have advice/knowledge on these issues. I love my car so much but I'm starting to think it's becoming a money pit
 

· Administrator
Joined
·
2,424 Posts
If it starts with a boost it sounds like a basic battery drain issue, considering the battery and alternator are both new I would recommend have a test done to confirm they are both functioning properly.
Just because they are new doesn't mean they are good. Defective parts are always a possibility
 

· Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
It started with a boost before I bought a new battery, after the battery was replaced my car was starting like a champ, now it won't start with a jump, lights come on but when I push start it just makes a click sound and the dash lights up, no crank , literally does nothing. Still waiting on dealer to call and tell me what's wrong, could it be a key fob issue? I've had some in the past and considered replacing but decided to wait it out due to how expensive it was along with the other repairs I was having. I got news that when it showed up the tow company hit one of their cars with mine and now my tail light is broke, landrover told me its my issue to get ahold of towing company, I'm waiting on landrover so I know how much it will be to fixed so I can bitch the towing company out and have them pay. Can you tell my new year has started off amazing
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top