Land Rover and Range Rover Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
My 2010 lr2 radiator fan keeps running, evan after you turn off car and will run battery dead.The battery was dead so I jumped it with a small jump box so I could drive to my shop about 100 yards away and the car went into reduced power mode ,
I then put the car on a battery charger and after about 10 minutes the fan on my car started just running with the car not started and the keys out,
and now it wont stop,so I just disconnected the cable so the battery would run down.
I pulled connector off fan and tested wiring before fan relay and it has 12volts all the time?
Does any one have any ideas?
 

· Registered
Joined
·
1 Posts
My 2010 lr2 radiator fan keeps running, evan after you turn off car and will run battery dead.The battery was dead so I jumped it with a small jump box so I could drive to my shop about 100 yards away and the car went into reduced power mode ,
I then put the car on a battery charger and after about 10 minutes the fan on my car started just running with the car not started and the keys out,
and now it wont stop,so I just disconnected the cable so the battery would run down.
I pulled connector off fan and tested wiring before fan relay and it has 12volts all the time?
Does any one have any ideas?
Did you ever find out what was wrong? Was it a relay? Fuse? Or the fan module? Mine started doing the same thing and I can’t find anything on the web
 

· very disco
Joined
·
3,025 Posts
A blown fuse won’t make something stay on, it will prevent it from turning on. Check your relay as those can fail in both always on and always off position.
 
  • Like
Reactions: ThorInc
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top